Frustrated on cloning Mifare

Hey there.

Getting frustrated on cloning a card to magic ring V2.
I own the Proxmark3 Easy and tried to use these manual to clone my card:

A get an error at the end:

[usb] pm3 → hf mf cload hf-mf-AAB7388B-dump-002.eml
hf mf cload: unexpected argument “hf-mf-AAB7388B-dump-002.eml”
[!] :warning: Try ‘hf mf cload --help’ for more information.

Any help is highly recommended. Please no Youtube Videos, as I´m working on a cruise line and Youtube is blocked for crew…

[ Proxmark3 RFID instrument ]

MCU....... AT91SAM7S512 Rev A
Memory.... 512 KB ( 60% used )

Client.... Iceman/master/v4.16191-351-g5b53bf803 2023-05-15 22:03:01
Bootrom... Iceman/master/v4.16191-59-gbfd2fc2a5 2023-05-17 18:30:08 
OS........ Iceman/master/v4.16191-59-gbfd2fc2a5 2023-05-17 18:30:37 
Target.... PM3 GENERIC


hf mf cload -f hf-mf-AAB7388B-dump-002.eml

for future reference you can add --help to the end of your commands to display the help text. It probably would have answered your question


It’s a gen2 chip, cload is for Gen1a


The keys on your ring will be factory default FFFFFFFFFFFF but you should still autopwn it to get the key file.

To set the block 0 to that of your original you can do this by using the hf mf wrbl command.

hf mf wrbl —blk 0 -k FFFFFFFFFFFF -d (block 0 contents of your card you wish to clone) —force`

For uploading the entire memory of your old card including block0 (so to also clone the uid) to the ring you will want to use the hf mf restore command.

Hf mf restore —1k —force -k (key file of your ring) -f (dump file of your old card)

I recommend writing block 0 manually outside of the restore command so you can confirm that it has been done successfully and then moving on to uploading the rest of the memory


Magic Ring V1 is Gen2, Magic Ring V2 is Gen1A:


Sigh, new drop post incoming


@Sven ignore my last post tho I’ll leave it for prosperity.

What you’re following is an old guide from before cliparser was in the firmware. You now must use parameters with your command.

As aox said, doing —help/-h will give you the helptext for that command but essentially to use the cload command all you need to do is define the file you’re upload within the -f parameter

hf mf cload -f hf-mf-AAB7388B-dump-002

Also what version of the firmware are you running? .eml files are a depreciated output and not present in the most recent release so if you are getting those with your auto pwn output you should update your firmware.


Happy new year and sorry for my late reply.
Everything worked out for me so far, except the update of my device.
Need to find some time to read thru everything and find a way to update.

Thanks a lot


This should do it for you…

cd proxmark3

git pull

make clean && make all





May I suggest
make -j

it will allow for parallel compiling and goes faster.