Help! Can't write to xNT

Just got my xNT today, and was so happy to have it read for the first time.

  1. I read it using NFC Tools.
  2. I tried to secure it with the Dangerous Things app, but it gave the error: “lock bits already altered”
  3. I set a password for it using NFC Tools, and I think that worked.
    Since then I haven’t been able to write to it.
    Tag writer claims it’s read-only, however NFC Tools says that it is writable.
  4. I have tried to delete the password using NFC Tools, but it just says “Identification Error”
  5. I ran xNT Support and got:
    Get Version: 00 04 04 02 01 00 13 03
    Page 00: 04 21 03 AE
    Page 01: 12 FF 38 85
    Page 02: 50 48 0F 00
    Page 03: E1 12 6D 00
    Page 04: 03 00 FE 00
    Page 05: 00 00 00 00

Page E2 :00 00 00 BD
Page E3 :04 00 00 00
Page E4 :00 05 00 00

Is there anyway to make it writable? Have I messed it up permanently? @amal

If you set the password with NFC Tools, then the only way to remove the password is with NFC Tools. You have to get it 100% correct, case matters, whitespace matters too IIRC.

NFC Tools does some password-mangling or something so no other app or utility will work. It also protects the entire tag as read-only, so it cannot be written to without the password.

I suggest you keep using NFC Tools to try removing the password. Good luck.

I’ve tried that several times with different versions of my password, but I get an Identification Error. If I try to set the password again, I get a write error.

I was wrong!
I had a stray newline at the end of my password and didn’t know about it. I was able to remove the password! Still getting the “lock bits already altered” error from the DT app but I can finally write to it!

That’s great! We had a tag where we moved the phone while using the DT app and it kinda only half-finished the process, and left it in that state where some lock bits were altered but others weren’t.

It’s possible to complete the process manually with another app but it’s really fiddly and not sure if it’s worth the effort.

Here’s the thread if you’re feeling adventurous:

1 Like