Help with proxmark3?

So I received a proxmark3 easy a little over a month ago, and I’ve yet to be able to make it work. I was able to get through most of the install process and get proxspace setup, save for the errors shown with the signature that were in the latest install video. However, I’ve not been able to actually flash the device, and this screenshot is what happens every time I try to flash the device. If the device isn’t plugged in, it will say waiting for device and once plugged in, it simply returns to a new line and allows me to enter more commands. Any advice?

Is it possible that I’ve bricked my device?

1 Like

Did u do





Yes, all of which give the same result of just returning to the next line with “pm3 ~/proxmark3$”

Can you issue a “ls” command and share the results?


Looks like you may be missing some files. I don’t have my pm3 in front of me to check.

Just want to make sure, did you follow the steps in this thread?

Getting started with the proxmark3 easy

I think I followed every step, but it’s possible I missed something. I did follow along with the video posted in that link as I installed everything.

Assuming I am missing some files, what’s the best way to go about fixing that issue? Delete everything from the working folder and start over from scratch?

Can you type in

notepad Makefile.platform

And make sure it says


(And save the file)

Once this is done, enter

git pull
make clean && make all

Disclosure: I’m just doing basic troubleshooting. I’m not fully sure what issue is, just trying to help out best I can. If this doesn’t work, someone else might have a better solution than me.

Just tried that process, and unfortunately, I still have the same result as before where it simply returns to a command entry state and never actually flashes the device, and doesn’t open the client


Hoping someone else has a suggestion.

You can try deleting the proxmark folder and follow the guide again.

I know amal recently updated the guide, but not sure how recent the video is… i noticed you mentioned a video, and “working folder” which amal talked about in the past, but when he updated the main post, he got rid of “working”. I think it was confusing people.

Hmmm, looks like I’ll go about deleting it all and trying to start from scratch


Just deleted the proxmark folder and everything related to proxmark, reinstalled, and I’m still dealing with the same issues.

Do you have open COM port in /dev/?
I would go first through syslog to see if there isn’t problem connecting.

I’m sorry, can you elaborate some? I’m able to see the device in device manager if that’s what you’re asking

With the proxmark3 plugged in, open up Device Manager from windows… expand the Ports section… post a screenshot of that

1 Like

Also what is the path for ProxSpace on your computer? Is it C:/ProxSpace ?

The path is ‪C:\ProxSpace\ProxSpace and here’s a screenshot of my device manager. It’s nested inside another proxspace folder because winrar put it inside of another folder, and I just left it rather than moving it to a root proxspace folder

Hi :slight_smile: It is, at the same time desperate, comforting to see that you have reached the same point as I have. It’s been a head-scratcher, I can’t move forward. Did you manage to solve it?

What OS are you using?
What guide did you follow?

I’m not to sure how helpful I will be here…

I was having the same issue just a few days ago. I ultimately ended up moving everything to root and trying again (following the DT install guide) and that worked for me.

However! I did find this video and tried this before moving everything and I was able to get it up and running this way as well.

Hopefully someone can chime in about the video…I’m wondering if this way works as it setups up an iceman install. I believe it’s the latest as well.