Invalid tag on xnt

So i have the xnt and it wouldn’t let me write to it for some reason anymore. Kept throwing back an error so I did a factory reset to it like it told me too and now it won’t ever read it. Android says its an unsupported tag type and then it gives me an error saying invalid tag. Nxt tag reader allows me to scan it successfully and it shows I still have my data on it but for some reason it doesn’t have a tag type. How can i fix this.

Update: it seems that it has two different messages on it. One blank one and one with the OG information. How can i get rid of one of them.

chances are that the OG message was larger and what you’re seeing is the new message, which is smaller, then the ndef terminator TLF which is FE , then remnants of an older message which was larger and written to more memory pages beyond the current message.

you can try to do a full scan with taginfo and post the memory contents (minus UID if you’re security conscious)

… or you can use the Dangerous Things Support Tool and write a blank ndef record and then try to write a new record overtop of that.

1 Like

I would however the data stored on it is quite literally my address and phone number and name. Is there any way I could direct message it to you.

Are you using TagWriter by NXP to write to it?

Yes

Have you tried this





1 Like

Yes. I cant even format it because it just says invalid tag. The only thing I can do is do a full scan. Thats it.

hmmm, bugger.
.
.
.

Could you try the factory default first, THEN the NDEF format.

I tried that. Thats what caused it to do this.

I saw that in your original post, but you can’t break what is already broken.

Can you try factory format followed by ndef formats, if it asks for storage size go for 888bytes

Did you try this?

Screenshot_20201007-162918

If that doesn’t work

Do you have a Proxmark by chance?

And for this bit

If nothing else has worked ,
and you dont have a Proxmark, and nobody else here has any ideas,

(Since Amal already has your details)
Rather than a DM to Amal, if you use the support tool on the DT website, by hitting the floaty orange help button

And have your TagInfo dump ready to share when asked

I have no doubt Amal and Michelle will be able to sort you out.
They are amazing

Dynamic Duo

2 Likes

I went ahead an ordered a proxmark3. What should i do with it when it gets here.

Did you try this? Do you have Android or iPhone?

Yes. I have an android. It just says can’t read chip type and gives me the invalid card error. My computer can still read it when I go to unlock my pc with it but all its doing is typing in the uid.

Gotcha ok… do you have an ACR122U by chance?

No. I have this. https://dangerousthings.com/product/kbr1/

Ok you will need to use the proxmark3 when it arrives to investigate what’s going on with the tag memory that might be causing the Android NFC stack to bail on reading or writing it.