Issue getting xAC to trigger relay

So I decided to go ahead and use one of the xACs I had to trigger my garage door. I initially bought 3, one for each of my bikes, but after doing the first one I decided to see what other projects I could use them for. I ended up having to replace the one on the bike after I rode in a storm and the waterproof compartment wasn’t so waterproof, so that leaves me with 1 left.

Yesterday I tried installing it but the relay wouldn’t trigger. I thought perhaps the DPDT I used was a bit large and the trigger current might have been too much so I ordered a pack of basic 12V SPDT marketed for auto use.

Well, these aren’t triggering either. I’ve tried two different power supplies, and both will trigger the relay no problem by themselves, but when I wire up the xAC it’s no good. I get the red LED on and measurements at the trigger wire show 7.3V when attached to a load (the relay), but 12V when left off. Do I just have a dud or…? Any help would be appreciated.

Wiring:
PS 12V -------> xAC red
PS GND --------> relay pin 85 and xAC black
xAC white ---------> relay pin 86

Wiring connections look right.

Did you use a diode between relay and xAC?
When the power turns off, the magnetic field collapses and can “kick back” at the xAC. Can hurt it.
If No, then add one.
If Yes, then turn it around and see if that works.

What kind of power supply? It seems awfully odd that it drops to 7.3V

Also, recheck for solid connections. It’s bit me more than once.

1 Like

Yep, diode on there and the right direction.

I’ve tried 3 power supplies now, just got done testing a larger 12V 5A unit. The other two were 12V 1A and 12V .5A. My Fluke shows correct voltage out of all three.

The 1A PS has a voltage selector on it and on a whim I set it to 9V and recorded ~5V at the trigger when connected to the relay. That’s the same roughly 40% voltage drop as at 12V.

If I can’t figure it out I may just pick up a 5V relay.

cat in lap, typing slow, one handed

definetly odd. not sure what causes it

open case. check for cold solder joints?

2 Likes

Are you able to use your meter to confirm there is 12v out on white wire while authorized tag is present? Disconnect from the relay and just test the output wire. Also, what is the red LED on the xAC doing?

12V on the white when not attached to anything, tested with all three power supplies. During all this the red LED lights only when a tag is presented.

Have a look here check the wires are plugged in in the right place.

ok… so now connect the diode and test on the other side of it… if you are not getting 12v on the other side of the diode, then either 1) your diode is backward, or 2) your diode is trash and needs replacing.

Diode is dropping normal ~0.7V. 8V on xAC side, 7.3V on relay side.

Ok so a few things…

  1. What is your source voltage? 12V or 9V? It really should be 12v…

  2. if you are supplying 12v, what is your current (amperage)? It should be at least 200mA (0.2A) at a minimum.

  3. if you are supplying 12v and at least 200mA and your white wire is only outputting 8v then something is really wrong here.

  4. If you are using an automotive relay then 7.32v isn’t going to cut it… probably why it’s not activating.

  1. 12V. The 9V was just a test I did from a variable PS I had.
  2. I tried three different power supplies, 500mA, 1.0A, and the last and still connected, 5A.
  3. Yeah, 12V strong being supplied
  4. Exactly, I’ve tried two different relays to make sure, a DPDT and SPDT and neither worked. I’ve got a 5V on the way today that it looks like I’ll end up using.

Omit the diode and try it… that’s all I can think of at this point…

What is the highest voltage you have tried?
The xAC is rated to 15V. but maybe if yo go for a 13V test…

If you give me 5 mins, I will do a quick bench test on mine

12V is the highest I’ve tried.

I just pulled the diode and it recorded 7.6V at the terminal, which was just enough to trigger the relay. However that’s not enough wiggle room for me so I’ll just wait for the 5V relays to come and also go looking through some of my spare power supplies to see if I’ve got something 12-15V to test, too.

Okay, I will stand down.

So this xAC is for your Motorbike?
Your battery will be Nominal of 12v but I would expect it would be around 12.7V
and maybe upto 13.7-14.7V when the engine running.

If you wanted to do one more test on a vehicle battery rather than Power Supply, that might answer your question…

The bike I did a while ago and that has worked wonderfully, this one is for the garage.

Thank you for all your help, I appreciate it.

1 Like

Little bit of history, these were originally automotive immobilisers. Surplus stock got reworked into the product we know and use. That’s another way of saying somebody took a soldering iron and made a few changes.

On the picture below, you should be able to follow the yellow line from the LED wires to the White wire. It should be 12V, except near the LED after it passes through the tiny little resistor. The trace passes through the board from one side to the other at Point A, and Point B.

I bet if you check the voltage (while under load from relay) at some point along that trace, that you’ll find it’s 12V like it ought to be.

My guess is that the modification circled in green didn’t get a good solder connection and is causing unnecessary resistance. That’s why it’s only checking low under a load.

3 Likes

I got really excited but sadly it’s measuring ~7V everywhere between point A and the plug. Also checked and it’s only about .3 ohm between them.

There’s a tiny voltage regulator to the left of the green circle. It’s been resoldered. Check that, and really that’s the last thing I can think of. It may not be worth further effort.

My only other suggestion would be a super up close inspection of the whole thing looking for cold solder joints or other odd stuff.

Like This.

8 Likes