Kali pm3 cannot detect proxmark3

I have recently decided to move my pm3 from my windows pc to my kali linux laptop. I have done all the steps as written on github (I hope) and when I open the pm3 client it either runs in offline mode or just waits for pm3 to appear.

Did you do the Make Access Rights step?

Does the pm3 show up when you run lsusb?

1 Like

The access rights step returned Ok, so I didn’t do it and lsusb does not change or show proxmark when I plug it in.

Did you log all the way out and then log all the way back in after doing the Make Access Rights step? If you run groups and see “dialout” I believe it should be good to go

The PM3 not showing up in lsusb is probably an issue too though

Yup, dialup is there, the proxmark did show up when i used sudo dmesg | grep -i usb as ttyASM0.

Do you have Modem Manager installed?

Came here to say exactly this.
Could be modemmanager (sudo apt-get purge modemmanager) [ Does Kali use apt-get? ]
Could be access rights. (sudo make accessrights )
Could be udev is confused out of it’s mind, so rebooting WITHOUT the pm3 plugged in then plugging it in, then starting pm3.
If that fails, try pm3 --list to see what ports it thinks are active. (and unplug those other things…)

Probably a rare use case, but personally if I have a ChameleonUltra, a FlipperZero AND the pm3 (rdv4) plugged in at the same time…stuff gets weird and confused in a hurry.

Did all of the above with no change, pm3 --list returns “[!!] No port found”.

Ok, so the proxmark3 isn’t seeing the device. (maybe we have a flashing problem…)
Is the OS seeing the device and assigning it a TTY?
What does
sudo dmesg | grep -i usb

Specifically we’re looking for any lines that say proxmark and any lines that say something like TTYACM[0123]… or any lines that say “cdc_acm”

1 Like

I am thinking of just doing a clean reinstall, mabe I’ve made a mistake along the way. I’m kinda new to linux, how do I make sure I remove everything pm3 related so I can have a clean install?

I don’t think it’s the PM3 client’s fault at this point, the computer should at least be detecting the PM3

Have you tried a different USB port/cable?

Tried both usb ports and 2 cables, no change.


Well, we’re out of my depth for linux at this point, but tonight or tomorrow I’ll try on a Kali drive and see if I have to do anything special to get it to show up

1 Like

Hey, sorry for the wait:

Unfortunately my fresh Kali live drive just works with my PM3 right out of the gate

if you haven’t had any luck yet, I would try the PM3 back on the original windows computer and make sure it’s still working there to rule out device issues