Phone's NFC tool opens instead of link when scanning xSIID (SOLVED)

I’ve used NXP tag writer to write YT links and other URLs to my xSIID and my phone, Samasung Note 20 Ultra, would automatically open the default app or give a list of options when no default app was selected. The only time my phones NFC tool would open would be when I just wrote text to my implant, and it would show the text. Unfortunately now though, my phone only opens the NFC tool and not a default app or list of apps. I’ve tried writing previous successfull datasets that NXP saved and still get the same NFC tool popping up. I’ve tried restarting my phone, tried force closing the NFC tool, tried disabling the always on top permission for NFC tool, and tried writing just text. But the NFC tool always pops up looking weird. I’m wondering if this is an issue with my phone, or if NXP is writing bad code. The picture is the NFc tool message that pops up.

gotta knock out the obvious but have you tried force closing NFC tools and doing it

1 Like

Lol I did. Every time something goes wrong, I have IT Crowd in my head “have you tried turning it off and on again?” XD
Even reinstalled it as well. But got some help from the discord server. DonFire pointed me to DevilClarke’s pineed message:
xSIID ndef screwed up recovery (works most of the time)

It fixed me right up!