Still new to NFC and failing

I have never read an NFC before with my phone but i know my phone should be able to read the BullsEye Tags. Still no luck after 2 weeks. I have taken all suggestions, took off my case, NFC is on, Android Beam and S Beam are on. I have tried holding the tag to the phone while the phone is on its home page and while the phone is in the “Read Tag” mode on NFC Tools and 2 other apps with no luck. Does anyone know if my BullsEye tags could be damaged? how can i tell if its me or the tags? Also any more suggestions?

Have you by any chance replaced the original battery in the phone or put on a different backcover? In many phones the NFC antenna is located on the battery itself to achieve maximum range(because it needs to be on the outer side of the battery), and if you have replaced the battery the new battery might not have the nfc antenna.
You could try with another phone and see it picks it up. If you don’t have access to any other phones you could probably even go to a store with phones on display and test the tags there.

What phone do you have?

What @TabSpaceTab said… here are some examples of the NFC antenna being built into the battery or back cover of the phone:

You should probably test your phone with a known good NFC device, as it is the most likely culprit.
You could:

  • Try sending a contact card to a friend’s phone using NFC to test your phone’s NFC capability.
  • Many hotel room key cards are NFC now. Try scanning one of those.
  • Buy some cheap NFC tags on amazon for testing. A quick search found $11 for 25 prime or $4.44 for 6 tags non-prime.

Again, what phone make and model do you have?