Updated to latest proxmark3 iceman rrg and things are strange

So I have done a bit pull and full make clean and make all. Then install the bootrom and fullimage to my pm3 easy 512m. Now for some reason my NeXT just reads as Hitag with an incorrect bit 1 as zero. I never changed my chip from the EM410x as it is my door entry. So thinking it was a fault on my part I thought … I’ll just LF t55 wipe and then LF t55 write b 0 d 00148041 . Now the door no longer reads me at all and the pm3 just thinks it’s an Hitag with bad bits on it?? Any ideas?

ED: I went back to the official repo of proxmark3 and did a full clean install. My NeXT worked 1st time. Right back to EM410x. There must be a glitch in the new iceman fork. So anyone looking to update… hold fire till whatever is wrong gets looked at…

1 Like

Someone else was having issues with Iceman fork too - I wonder if the LF code got played with?

I am really far from an expert here but I’m pretty sure proxmark3 hardware that isn’t the rdv4 may need some special compile options due to lack of memory? @TomHarkness any thoughts?

I have recompiles and checked the code on 4 of my PC’s from linux to windows. Even on 3 of my SBC setups. These all worked not a week ago with the last repo from iceman1001 rrg fork. And I am a programmer (masters in computer science). I was more just stating a code error that I havent tried to pinpoint really. More about letting people know (pm3 easy people) that if they are having problems that’s where it’s coming from. I reverted to the official proxmark3 repo on github and reflashed the pm3 easy (for the 10th time lol . Lots of iceman tries). All is 100% on official. Hope this helps with people thinking there chip is broken when it isnt.


It was me also having issues with Iceman fork - posted on proxmark forum and the great iceman himself reviewed my data dumps - There is nothing wrong with my PM, nor my T5577, nor the software, everything looks good, but the detect command still doesn’t work. Not sure what to make of it from there so I’m gonna go back to official when I have time to play around again.

Hi, I found that what ever the problem was back then it has been fixed. I didn’t find the fix in any documentation on the guthub but again just a cursory glance… all told do a delete of the proxmark3 directory then fully reinstall from the git (iceman1001 rrg). Should be fine… let us know :slight_smile:


Oops, forgot to update here! Yeah I found the same thing about a week after my last post. Reinstalling and reflashing made all of my issues vanish.

Props to Iceman and the RRG, they do great work!

1 Like