VivoKey for iOS Dev Update:

Why am I having so much trouble?

Running the current version of VivoKey app on iOS 14.5 using Spark 2.

I can’t seem to login to the VivoKey members forum from the link in the VivoKey app.

The following is the sequence of events I’ve been following.

I open the app and scan my Spark 2

I click the Members Forum link

I click “Touch to login”

I click “Open”

I scan my Spark 2

I get denied

Has this happened to anyone else? What am I doing wrong?

I had that a couple times, for me it was just a bad read angle. Tried it again with a little adjustment and it worked.

Edit: I just tried it and was getting the same issue. :frowning: However if you go to in your browser and start the process from there it might work. It did for me at least.

In this case, I can rule out a bad read.

I thought maybe the link was screwed up but once I click it in this post I can see it works.

So I play along and click “Touch to login”

Here we go! Except when I go back as instructed…


That one I haven’t seen. :confused: I know it seems like basic troubleshooting, but have you tried clearing out recent history, cache, etc? Turn it off and on again perhaps?

I got it to work one time using your link, could be VivoKey’s link in my profile is bad or I’m not quick enough.

Could be my Spark 2, it’s always seemed… hesitant, this is why I chose to hold off on installing it.

Sounds weird

I will drop in an @amal and @fraggersparks here, to check it out at their VK end.

Check out this recent thread, that MIGHT have something to resolve the issue for you…hopefully

Let us know if you have any luck

Good luck

Hey, I’m Julio, I made this app.

I think I’ve already answered this before.

The link inside the app will not refresh the website. Many times the website will be saved with their current values and will not be forced to refresh.

In detail:
That QR includes a “challenge” identifier from the VK server, and this challenge expires in a couple of seconds after being generated.
If you refresh the page and let more than 20-30 seconds pass, you will see that the QR code will automatically refresh.
When you open the members.vivokey website from inside the app, if it was on cache it will just load the page (with an expired QR code).

The easy way to assure you get a fresh challenge is just to refresh the website before jumping back to your app. New credentials should replace the old ones in the app.

I believe this to be the case, as long as I access the forum from outside the app, everything seems fine.

I got it working for now, my apologies for the disturbance.

No worries, thing is that the app can only tell the system: “open this website”.
If the website was already open (even on a previous tab) it will just display it on screen and not refresh it.
The website’s page actually is running a JavaScript that should automatically refresh it.

But if its loaded from a previously opened page then it will fail. Either remove any opened tab on this address or hit that refresh button. ^^

1 Like

I can’t find the app in my usual app stores, like the US. Has it been revoked or limited to JP or something?

1 Like

In the mexican store:

Yes, this one, and it can be downloaded without problem

Thanks guys. It looks like it was published as iPhone-only, I have the latest iPad mini with NFC and everything but the App Store was hiding the app from me. PS wow, I’m reading the NFC chip on my iPad has no antenna, so no NFC apps for iPads after all these year. Just wow!

IPAD MINI HAS NFC?! I’ll see what I can do for the next update about the iPads. I would have to change the code to not run on iPads without NFC.


No, no iPad’s have NFC as a feature. A few teardowns show that there is an NFC chip on the board that is used internally for other functions, but it was never intended for actual NFC use - it has no antenna so I’m not sure what other features Apple are using from it.

Depending on the chip, some of them have the ultra wide band support integrated into them… not sure if that’s something that iPads support, but if they do then that may be it. The other thing is could be is part of a security module, but since Apples has their own secure enclave I doubt that.

Hello guys, I got a recommendation on asking for help regarding my issue in this thread aswell, so here I am. Could you please take a look at it here? VivoKey App iOS Spark 2 Registration Bug. Thanks! :slight_smile:

So what’s the deal with Ios vivokey login failed

I put it on the back burner for a long time, but it’s slightly annoying now

I count on one hand the number of times I’ve managed to login to vivokey forum

Log into app, just fine
Click vivokey link
Brings up a scan vivo key qr landing screen
Click link
Opens back up vivokey app
…login failed

…every time

It’s not a read issue, it’s something on the other end

1 Like

Agreed I cannot login in to the forum on my phone period. If I use my phone to login in on my tablet or laptop no issue.

I can appreciate the time and hard work put into this app for apple users.

I agree, it isn’t very fluid having to close tabs and clear cache every time I wish to use it.

Apple users should have clear expectations of VivoKey’s usability before purchasing those implants.