xM1 ATQA:00 Anticollision Error

Looks like I am having the exact same problem as Jirvin.
Went to change my uid on my implant everything went successful according to my proxmark rdv4 and now I have ATQA:00 Anticollision Error. Everything I have read and tried has said it was successful but no change. Any direction would be greatly appreciated.

1 Like

hw status
hw version
hw 14a info

Last one while scanning the tag

1 Like

Here you go these are the results. Thank you

[usb] pm3 --> hw status
[#] Memory
[#] BigBuf_size…40444
[#] Available memory…40388
[#] Tracing
[#] tracing …1
[#] traceLen …0
[#] dma8 memory…-2113724
[#] dma16 memory…-2113724
[#] toSend memory…-2113724
[#] Current FPGA image
[#] mode… HF image built for 2s30vq100 on 2020-07-08 at 23: 8:19
[#] Flash memory
[#] Baudrate…24 MHz
[#] Init…OK
[#] Memory size…2 mbits / 256 kb
[#] Unique ID…0xD5690C23DF16B02A
[#] Smart card module (ISO 7816)
[#] version…v3.10
[#] LF Sampling config
[#] [q] divisor…95 ( 125.00 kHz )
[#] [b] bits per sample…8
[#] [d] decimation…1
[#] [a] averaging…Yes
[#] [t] trigger threshold…0
[#] [s] samples to skip…0
[#] LF Sampling Stack
[#] Max stack usage…3976 / 8480 bytes
[#] LF T55XX config
[#] [r] [a] [b] [c] [d] [e] [f] [g]
[#] mode |start|write|write|write| read|write|write
[#] | gap | gap | 0 | 1 | gap | 2 | 3
[#] ---------------------------±----±----±----±----±----±----±-----
[#] fixed bit length (default) | 29 | 17 | 15 | 47 | 15 | N/A | N/A |
[#] long leading reference | 29 | 17 | 15 | 47 | 15 | N/A | N/A |
[#] leading zero | 29 | 17 | 15 | 40 | 15 | N/A | N/A |
[#] 1 of 4 coding reference | 29 | 17 | 15 | 31 | 15 | 47 | 63 |
[#] Transfer Speed
[#] Sending packets to client…
[#] Time elapsed…500ms
[#] Bytes transferred…284672
[#] Transfer Speed PM3 -> Client = 569344 bytes/s
[#] Various
[#] Max stack usage…4120 / 8480 bytes
[#] ToSendMax…-1
[#] ToSend BUFFERSIZE…2308
[#] Slow clock…29605 Hz
[#] Installed StandAlone Mode
[#] LF HID26 standalone - aka SamyRun (Samy Kamkar)
[#] Flash memory dictionary loaded
[#] Mifare…917 keys
[#] T55x7…110 keys
[#] iClass…7 keys

[usb] pm3 --> hw version

[ Proxmark3 RFID instrument ]

client: RRG/Iceman/master/v4.9237-823-g1689a731-dirty-unclean 2020-08-29 22:01:27
compiled with MinGW-w64 10.2.0 OS:Windows (64b) ARCH:x86_64

external flash: present
smartcard reader: present

[ PROXMARK3 RDV4 Extras ]
FPC USART for BT add-on support: present

[ ARM ]
bootrom: RRG/Iceman/master/v4.9237-823-g1689a731-dirty-unclean 2020-08-29 22:00:55
os: RRG/Iceman/master/v4.9237-823-g1689a731-dirty-unclean 2020-08-29 22:00:58
compiled with GCC 9.2.1 20191025 (release) [ARM/arm-9-branch revision 277599]

[ FPGA ]
LF image built for 2s30vq100 on 2020-07-08 at 23: 8: 7
HF image built for 2s30vq100 on 2020-07-08 at 23: 8:19
HF FeliCa image built for 2s30vq100 on 2020-07-08 at 23: 8:30

[ Hardware ]
–= uC: AT91SAM7S512 Rev A
–= Embedded Processor: ARM7TDMI
–= Nonvolatile Program Memory Size: 512K bytes, Used: 287928 bytes (55%) Free: 236360 bytes (45%)
–= Second Nonvolatile Program Memory Size: None
–= Internal SRAM Size: 64K bytes
–= Architecture Identifier: AT91SAM7Sxx Series
–= Nonvolatile Program Memory Type: Embedded Flash Memory

[usb] pm3 --> hf 14a info

[=] Card doesn’t support standard iso14443-3 anticollision
[+] ATQA: 00 00
[usb] pm3 --> hf 14a info

hf mf cwipe 01020304 -a 0004 -s 08

Make sure you have a solid coupling with the implant. This will wipe the tag and set the ATQA properly to fix that error. After this commands, try a

hf 14a info

1 Like

When did you get your xM1?
Where is it installed in your hand (any tags near it)?
What command(s) did you try before getting this issue?

Put the tag on the PM3 then run hf tune ensure you get around 42V (if not, reorientate the tag until you get ~42V) then stop the command.
Run what @cexshun said but run a hf 14a list after the hf 14a info

Probably not what you want to hear but I never could resolve my issue and, with the help of others (mainly Iceman), concluded that the tag was bad. Before this definitive conclusion @amal was also helping out and sent me a replacement. I recently got the implant removed, now waiting until my hand heals until I implant the replacement.

Jirvin I have followed your post on the proxmark forums and here. I have done everything you have with the exact same results. I got my implant 2 weeks ago. I doubt I will have any better luck with this than you had. As it is exactly the same issue right down to the 14a list it’s all identical.

I have tried a wipe about 20 times now to no avail. Here are the results from this one

[usb] pm3 --> hf mf cwipe -u 01020304 -a 0004 -s 08
[/]wipe block 63
[+] Card wiped successfully
[usb] pm3 --> hf 14a info

[=] Card doesn’t support standard iso14443-3 anticollision
[+] ATQA: 00 00
[usb] pm3 --> hf 14a list
[=] downloading tracelog data from device
[+] Recorded activity (trace len = 21 bytes)
[=] start = start of start frame end = end of frame. src = source of transfer
[=] ISO14443A - all times are in carrier periods (1/13.56MHz)

  Start |        End | Src | Data (! denotes parity error)                                           | CRC | Annotation

0 | 992 | Rdr |52(7) | | WUPA
2100 | 4468 | Tag |00 00

Hmm, that cwipe command should have specifically set the ATQA to 00 04.

Shouldn’t be necessary, but have you tried a remagic?

script run remagic.lua

Im wondering now if @amal got a bad lot of chips. Grey market electronics from china are never that reliable. Let’s hope it was just these two. It might be worth opening a few random xM1’s and try cloning to them to see if this error keeps happening.

Yes this is always a problem… our first batch of xM1+ (when it was called xM1+) had this problem, but this batch has not seen these issues so far… but now two. We are keeping an eye on it and trying to get feedback from our chip upstream about it.

Can you post the command(s) you used for this?

I was just testing the chip to see if it worked so just using the standard generic uid
hf mf csetuid 01020304

1 Like

oh yes a few times. No luck it says its successful but i still get the same error

Since it looks the same as mine but we shouldn’t just assume and skip over the troubleshooting steps first.
Usually when you get an ATQA:00 error, first step is to use hf mf csetuid as you can manually set the ATQA. If that doesn’t work (or if I’m feeling (very) lazy) a hf mf cwipe usually does the trick. If they both don’t seem to work or get you back to ‘normal’ then script run remagic is usually the last resort.

If this was a normal tag (i.e not an implant) additional advice would be to put some distance between the reader. This could be replaced with make sure you have decent coupling with the implant and can get consistent reads.

From talking to Iceman, he recommend trying the following (copy it all then paste it (last command you will have to hit enter on)):

hf 14a raw -p -a -b 7 40
hf 14a raw -p -a 43
hf 14a raw -c -p -a A003
hf 14a raw -c -p -a ffffffffffff787788C1FFFFFFFFFFFF
msleep 2000
hf 14a raw -c -a 5000
hf 14a raw -p -a -b 7 40
hf 14a raw -p -a 43
hf 14a raw -c -p -a A000
hf 14a raw -c -p -a 01020304049802000000000000001001
msleep 2000
hf 14a raw -c -a 5000
hf 14a info

When you post your command outputs, use the code blocks to contain it like:

[code] Command output here [/code] 

Would be interested to know if you were able to read from it before (trying to) write to it?
When you wrote to it, did you move at all (shouldn’t be an issue but just curious)?
When did you buy your implant? I know you answered before but wasn’t sure if that was date of purchase or install.


FYI, we are sending 20 xM1 chips to Iceman for analysis and destructive testing. These are assumed working chips, but we are going to get to the bottom of this.


Yes very interested in this as well.

1 Like

Oh thank you I really wanted to know how to do that code box so here are the results

 [usb] pm3 --> hf 14a raw -p -a -b 7 40
received 1 bytes
[usb] pm3 --> hf 14a raw -p -a 43
received 1 bytes
[usb] pm3 --> hf 14a raw -c -p -a A003
received 1 bytes
[usb] pm3 --> hf 14a raw -c -p -a ffffffffffff787788C1FFFFFFFFFFFF
received 1 bytes
[usb] pm3 --> msleep 2000
[usb] pm3 --> hf 14a raw -c -a 5000
received 0 bytes
[usb] pm3 --> hf 14a raw -p -a -b 7 40
received 1 bytes
[usb] pm3 --> hf 14a raw -p -a 43
received 1 bytes
[usb] pm3 --> hf 14a raw -c -p -a A000
received 1 bytes
[usb] pm3 --> hf 14a raw -c -p -a 01020304049802000000000000001001
received 1 bytes
[usb] pm3 --> msleep 2000
[usb] pm3 --> hf 14a raw -c -a 5000
received 0 bytes
[usb] pm3 --> hf 14a info

[=] Card doesn't support standard iso14443-3 anticollision
[+] ATQA: 00 00
[usb] pm3 -->

No i did not move at all, and yes I read from it no prob before. I purchased the implant Aug 23.

1 Like

Did you try to use your rdv4 with the plastic case on or raw pcb antenna?

Case off. The implant is on the back of my hand so I can see right where the coupling sweet spot is. I was able to read repeatedly no prob. I tested before I wrote.

I noticed having the antenna right on the skin was poor coupling. The best spot for me anyway was to turn the rdv4 face down I have the blue shark module installed so it leaves about 1/4 inch space between my skin and the antenna. When I did this I got consistent reads and no errors.

1 Like

Does tagreader on your phone read anything from it?

Nope its like its not even there.