Xnt isn't read by my phones


yesterday my xNT was injected by my piercer.

I have 2 androids and try to read the xNT but i cannot get a red … :frowning:

But I have tried two different androids and cannot get a read. :roll_eyes: any pointers?

When I try to find the chip under my skin, I can not.

Is there any chance that the application process of the chip has given problems?

Or do I need to wait a little longer to test again?

Hello there, I tried looking up your order by your email address, can you provide me your order number?

I look forward to hearing from you :blush:

My best,


1 Like

Sorry i bought mine on a event in Brazil, Roadsec BH. I isn’t have a order here. But this is only a doubt.

If i have problems with the chip i will try to buy another here with you.

Hi cybernetus,

That’s not necessary, we can help. We just want to pinpoint the lot your xNT has come from in the event there truly is a technical problem, which is pretty rare with our xNTs, but this does not mean you necessarily have a faulty unit.

Here’s what I can tell you, and what you can verify among the posts here from others immediately after installation; that even mild swelling will impede proper coupling. The range between the reader and the bio-glass encased chip should be within 2mm; therefore swelling and placement (depth) are factors in getting a proper read.

Give it a couple of days and try again. Most people are pleased to find that letting a brief amount of time pass usually solves this issue as swelling diminishes.

If you still find a lack of response. Come back and we have a few suggestions we can offer to validate the integrity of the chip.

My best,


1 Like

Thanks for your reply :slight_smile:

I will wait more days to test again :slight_smile: Thanks for your help .