xSIID used for Schlage door access

I am looking / hoping I bought the correct implant for my door access system at work. I got the xSIID with blue LED. We use a Schlage system and my access card is a 8540M1 which is 13.56MHz ISO14443. From what I could tell by reading it should but I was told by a friend is may not because most of the 13.56MHz do more than just transmit out there serial number.

NOTE my coworker who is the locksmith said all he needs is the six digit number from the back of our cards.
He said give him the serial and it will work.

Just concerned I am way off and doing this for nothing. Thanks in advance.

downloand NP TAGINFO AND/OR NFCTOOLS, tap the card to your phone and send a screenshot of the output :slight_smile:

also if your the owner/programmer of the lock chances are you will have the ability to add new cards to the door so you’ll most likely be able to enroll your implant even if the mifare version isn’t the same. it can work off 14a UIDs most times I’ve seen it anyway

1 Like

Tag Type: ISO14443-4
NXP-Mifare DESFire EV1 4k

Tech available: IsoDep, NFCA, NdefFormatable

Gives a serial like a mac address with 7 sets of number not 6.

ATQA SAK ATS all have values such as 0x00

Does this help?

The NTAG I2C chip in the xSIID is also a 7 byte UID so that part at least matches up… but what’s annoying here is that this doesn’t mean compatible. The DESFire EV1 chip has the ability to store secure “apps” (files) on board and are often used for extra security, but some locks and systems just use the “serial number” (UID) alone and ignore the secure capabilities… then claim “hey look we use secure cards, it’s secure!” … rare, but does happen.

The real bummer here is that even though both chips (desfire ev1 and ntag i2c) are ISO14443A with 7 byte UIDs, and let’s assume the lock only uses the UID and nothing else on the DESFire EV1 card, this still doesn’t mean compatible… for whatever reason some firmwares in locks etc will be written in such a way as to basically limit the types of chips able to be used… even distinguishing between various chips in the ISO14443A family. Sometimes this is on purpose, but I believe that more often than not, it’s laziness and they have written some sort of rigid code that only works with specific chips based on commands and responses that only that chip type would respond to and not others in the ISO1444A family.

Think of ISO14443A like a telephone line… we are both using a telephone and can hear each other, but we speak differently languages… the ISO standard is all about setting up a way to communicate, not dictating the communication itself… so different ISO14443A chips can have different memory structures and commands. Yes the reader can talk to it, but if the application layer controlling that reader is looking for specifics for a DESFire EV1 then your xSIID won’t work.

The other possibility is that you’re having an actual read problem. To test this, you could get an NTAG216 card off Amazon or if you want to test the same chip as is inside the xSIID, you could get one of our NTAG I2C test cards;

I have not tried yet. may xSIID shows up Monday and I am having it installed Friday. So I won’t know for a bit but I hope my work buddy can just program the chip for the system or other way around. (fingers crossed)

If it doesn’t do you have a recommendation for identifying what is needed. Or what info so I need to pull out of the locksmith at work to order the correct chip. I’ll order the NTAG card if needed.

Thanks in advance!

1 Like