Anyone here have a solution for kbr1 scan freezing the VMware Workstation 17 Pro?

I have a VMware® Workstation 17 Pro 17.5.0 build-22583795 just updated earlier I use KBR1 and my XSIID to login here but recently it is causing to freeze VMware® Workstation 17 Pro I also tried upgrading my virtual machines into 17.5 but it still freezes also I tried to change USB combability into 3.1 USB than 2.0. Anyone here have virtual machines in VMware® Workstation 17 Pro problems with kbr1 freezing scan and found a solution to the freezing after scanning your bio-chip implants?

1 Like

Found the reason for the freezing etc. it’s because it types out only the first 2 digits and spam out the second integer. Seems a good zero-day for the latest VMware® Workstation 17 Pro 17.5.0 build-22583795 who have KBR1 and chip-implant since the OS already freezing and cannot do anything to it even closing the terminal or ALT+F4, the only solution is restarting the OS to use it again.


That’s odd. I’m on VMware pro 17 and my kbr1 works flawlessly. Did you install the advanced keyboard drivers at setup?


Just tested to confirm on kali. See video please. Did you manually enter the UID from your chip when you set the pw?


Just jumping in to say Thanks, Your first 3 posts on the Forum, all very constructive and helpful.

It hasn’t gone un-noticed

Much appreciated


@Pilgrimsmaster thank you, always glad to help out where I can! I hope to contribute as much as possible to the community and I’m super jazzed to learn from everyone. Have a wonderful night/day my friend, whatever the case may be :upside_down_face:




haha I didn’t even notice that. Thank you! sheesh, now I gotta put my system time off ON PURPOSE :rofl:

1 Like

that’s 17.5.0 build-22583795? I re-install to 17.0.0 build-20800274 now it works flawlessly like before.

1 Like

Do you mean this one? yeah, I probably accidentally did.

No, I wasn’t referring to guest isolation/encryption or enhanced security. I was asking if you installed the enhanced keyboard drivers when you installed vmware? Please see image for reference.

My second question was HOW did you set your pw? Did you attempt to just scan it or did you type each digit in manually? Either way, glad you got it working now.

Just FYI, I am on the latest vmware release. I seriously doubt this is a vmware issue. Was there a specific reason for updating the vm’s as well as vmware? I might be wrong but I would think that keeping vmware up to date as well as the guest-os is sufficient. To my knowledge individual vm upgrades via the vmware GUI is not recommened normally.

The pw in my ParrotOS also was scanned by KBR1 etc. alright I’ll try to update in 17.50 tom. I probably checked on enhanced keyboard etc.

Also do you mean this one is not recommended?

Btw do you use your bio-chips too as login pw? Do you have it on PIN module for Linux/GNU like for Windows PIN? How can we use PIN in Linux/GNU? - Support - Dangerous Things Forum I never though you can use Rohos in Linux/GNU too!

I’m saying I do recommend you use enhanced keyboard drivers. In answer to your second question even though the screenshot is not correct the idea is. Yes, I do not believe it’s recommended to upgrade your parrot vm in the vmware GUI. Someone with more knowledge will correct me if I’m wrong I’m sure though. To upgrade parrot just use normal apt update/upgrade.

That’s what fucked my keyboards the “enhanced keyboard drivers”. Yeah, I know how to apt update/upgrade everyone who uses Linux/GNU should know this, also I’m talking about the Hardware combability in VMware Workstation Pro some have lower version like mine still in version 16 etc. but when VMware Workstation get an upgrade, I will do them. I just got my bio-chip implant last year 2022 and I’ve been using Virtual Machines back in 2012 for Linux/GNU/Backtrack etc. so I didn’t know KBR1 and chips implants here could crash the system it seems that’s a valuable bug/asset.

You realize when you upgrade your vm’s to the latest major release you likely lose backward compatibility right? It’s normally not worth it IMO. As for the kbr1 “causing crashes” I fail to see how an HID keyboard emulator would do that. Perhaps you can explain it to me?

You can still downgrade your virtual machines Manage → Hardware Combability. I cannot also do shortcut like CTRL+SHIFT+C or CTRL+SHIFT+P (Copy-Paste in terminal) so I don’t think this is just the kbr1 but I guess the they got messed up with enhanced keyboard since kbr1 are “keyboard wedge” style RFID readers that acts like a USB keyboard when plugged into a host computer.