ApexManager 2.0.5 improper coupling - solved

Hey Fam,
Swinging by to drop a solution to an issue I’ve just noticed.
So ApexManager got recently updated on my android phone to version 2.0.5
I’ve tried today to read the chip with the manager and got improper coupling. Sh*t
First I was thinking the free memory applet got either incompatible with the new version or my chip got belly up`ed. Tried fidesmo, all applets showed correctly. I’ve decided to reinstall the free mem applet, but the drama with the manager continued.
Well, I went into apex manager app info, force stop, delete cache and data, restart app. Now the manager reads my apex just fine. That’s all


Haha holy shit we were just scratching our heads about that! Thanks :slight_smile: we had beta versions on our phones too.

We’ll confirm shortly.

1 Like

Did you have a previous version of AM installed by any chance?

Before you got 2.0.5 that is

Looks like it

I did, but I do not recall what version it was, and I have no idea if Android logs this anywhere( so I can check). Should be whatever was published to play store, before the update

I’ll put in some more detailed error handling on failure to synchronize. That way it’ll be easier to debug these things in the future

1 Like

I believe the issue is with local database changes. The old version uses a different local DB configuration under the hood, and I believe it’s conflicting with the new versions implementation because it tried to keep the old one’s local files after updating to 2.0.5. I should be able to handle it with an update.

No worries, and you’re welcome :slight_smile:

1 Like

Thanks for pointing it out!


Holy shit it worked!


You can also just reinstall the app

Did that it didn’t work.

Ah sorry, it worked for me

1 Like