Bluetooth Connection Issue (Flipper -> Android)

I’m currently using the most updated version of the Unleashed firmware, and the most recent beta version of the Flipper app for Android. Previously I was on the main release channel for both the firmware and Android app and experienced the same issues. I’ve also made sure that location is enabled in the Android app, and that Bluetooth is enabled on my Flipper.

The app can “see” my Flipper, but when I click “Connect” it lags for a couple of minutes with the spinning loading wheel and then reverts back to the “Connect” button. I’ve tried restarting both devices, uninstalling/reinstalling the Android app, and using multiple firmware versions. Any thoughts as to a potential solution?

Did you try a “forget” then new connection?

just clutching at straws here, it sounds like you have tried everything I would have also…
the only time I have seen what you describe is when my location in not on, but you have confirmed that…

1 Like

Unfortunately I can’t “forget” the device as it isn’t fully connecting in any fashion.

This is the closest I get:

@Pilgrimsmaster Had to reset the Bluetooth (on both Flipper + Android) five times and do a DFU recovery, but we’re back in business!

1 Like

that’s a bullshit solution, but at least it’s working.

I wonder what it was??? :man_shrugging:

1 Like


1 Like


some times it shows the device but not connect try to update firmware

I’m getting all sorts of nondescript and annoying bugs/crashes in the latest Unleashed firmware, but Bluetooth hasn’t been an issue so far. I actually don’t think I like this firmware. 'Considering going back to stock like a noob.

I have no issues with RogueMaster…

not saying it’s better, they are all the same, but I’m not experiencing any bugs currently

I just switched to RogueMaster yesterday after seeing this thread (previously using unleashed) and quite like it so far. Not sure if it will solve your problems of course, but I’d suggest giving it a shot before going stock.

1 Like

Thankfully my BLE issues went away after multiple setting resets and a DFU repair, but oddly enough I actually did try loading the RM firmware a couple times and it bricked upon install each time. Did you install via Bluetooth or directly with qFlipper on your desktop?

I installed via qFlipper on desktop

1 Like

I haven’t updated since the first one, but

The touchtunes remote isn’t mapped right,

And if I hold the center button down to change the background, it may or may not reboot.

I hadn’t noticed, but just checked, I had an ~“api mismatch” so no worky worky

I did mine about 15 times with no issue