(*****) Digital Logic DL533R USB Dongle PC/SC reader

Here’s another great NFC reader from Digital Logic: the DL533R USB Dongle.

I have quite a few Digital Logic products, and they all work great. This little guy is no different: it’s Wrigley’s packet-sized but it packs the punch of an ACR122U. Check it out:

That there with the very thin USB cable I soldered out of an old USB mouse tail is my new travel PC/SC reader.

And if you’re worried about drivers, worry no more: this guy is compatible with the stock Windows driver or open-source libccid driver under Linux: no need to install anything, it works right out of the box.

Note that the DL533R is the PC/SC version of the reader. If you need the libNFC version, choose the DL533N. This nomenclature applies across the range of non-uFR Digital Logic products (uFR being their proprietary API that’s neither PC/SC nor libNFC). I assume the performances are identical for the -N version, because that holds true with my -R and -N XL readers. But in fairness I haven’t tried.

€39.90 - well worth the money if you need small, powerful and no-fuss.


That mega is no joke

I still like my wave nano for form factor and it packs a punch but they price is much more attractive

Yeah well, for its size, it has the exact same range as the flexNT.
It does more than a flexNT though, and probably needs more power. I suppose that explains it.

Actually it wouldn’t work for me. I don’t know where you wear your implants, but there’s no way I could present most of mine to a reader hanging vertically off a laptop’s USB port. That’s why I never got one - price aside.

That does look quite “handy” :raised_hand_with_fingers_splayed:
Good size, okay price

I purchased this device. Ordered on May 13th, and it arrived at my house (USA) on May 23rd. I did purchase the express shipping.

@anon3825968, could you help me out? Can’t seem to get it to work. I plan on using it similar to the kbr1, to log into my windows computer (if that’s even possible).
I found their DL533R Repo. I made the change in Regedit, but still doesn’t seem to read.

(Not sure if I’m supposed to create a new thread under ‘support’ or if it’s ok to post here, sorry if I’m not supposed to).

It shouldn’t need a driver. It should be recognized out of the box by the Windows driver.

I haven’t tried it though. I don’t use Windows. I’ll bring mine to work and I’ll try it out, and I’ll post a screenshot.

They way I see it, Rosco did the review at the top, anything not covered or support needed, this seems like the logical place to ask it.
Effectively adding to the review.

However if the OP (Rosco in this instance) wants it moved, I’m happy to oblige.

1 Like

Yes, I realized that after I posted it. Windows automatically installed the driver. I’m just a little confused on what this device is supposed to do I guess. I figured it would be like a plug-and-play thing, but guess not. Not sure what software I need to use it as a keyboard.

I do have to wonder if this works out of the box with vivokey-codes? I expect it should since you say it works out of the box with the stock pcsc driver.

Okay @TheCyborgFirefighter. It seems Windows is a lot more of a bitch than I expected. But… I figured it out :slight_smile:

@DigitalLogic hint hint: you might want to know about this one.

First of all: if you plug in the device, Windows should indeed support it out of the box with the Microsoft WUDF driver:


However, if none of your PC/SC applications seem to see the reader, that’s because there seems to be a permission issue with at least Windows 10. To fix it:

  • Run regedit, right-click on Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Calais and select Permissions:

  • Select Add > Advanced > Find Now and look for LOCAL SERVICE:

  • Select LOCAL SERVICE, give it Full Control and Read rights:


  • Close regedit, reboot. Then try your favorite PC/SC software. For example Rohos Logon Key:


Or here, the Fujitsu mPollux DigiSign client (Finnish ID digital signing thingy):

Or Digital Logic’s own SmartCardDemo utility:

I assumed Windows worked straightaway but this doesn’t seem to always be the case. In particular, from what I can tell, this permission problems seems to happen on Windows 8 machines that were upgraded to Windows 10, rather than machines that came with Windows 10 from the start. Sorry about that, I should have checked before making assumptions.

On the other hand, it goes to show that Windows is shit and you should run Linux :slight_smile:


If you mean vivokey-codes under Linux, it most certainly does. In fact, I use that little guy for that very purpose when I travel with my laptop.

And you are correct: vivokey-codes can use any PC/SC NFC reader, and the DL533R is recognized rightaway by PCSC-Lite under Linux without having to do anything special.


Hmm, Still a no go. I tired running the SmartCardDemo.exe and it says “SCardConnect Fail”.

Not sure if I’m doing it right.

Hold on a sec… I think I know. But I need to remote-connect to my work machine.

I can’t connect. It must be down. But do this: run services.msc and check that the smartcard service is running. If it is, stop it, give it the same permissions as Calais above and restart it.

Other question: if you connect an ACS122U, does it work?

My Windows box is starting…

And make sure it’s running as LOCAL SERVICE:

Don’t have one. Only thing I got is a kbr1, and a YubiKey 5 NFC

Local Service is selected for Smart Card.

The KBR1 is a keyboard wedge (i.e. it’s seen as a HID device, like a keyboard). Totally different beast - kind of a lowest common denominator RFID reader that doesn’t do much of anything interesting but does it everywhere without having to install anything.

The Yubikey 5 NFC is a NFC tag, not a reader.

Hmm well, as least I think your smartcard service is running okay, else you would have had a SCardEstablishContext error.

Do you see the menu in the SmartCardDemo utility? Cuz if you do, it works :slight_smile:

Try another PC/SC utility, like Rohos (which is what you want to use to log into Windows with an implant anyway) or the Yubikey Manager.

EDIT: Also, I suggest getting an ACR122U. They’re cheap, and kind of the gold standard for PC smartcard readers, and PC-based implant readers. I don’t think you can be an implantee without owning at least one of those things :slight_smile:

Yup lol. Was just listing what I have.

Seem like I finally got it working, it could have been bad reads…
Maybe I’ll try out Rohos.

Thank you so much for your help.

Alright. Good news!

Yeah give PC/SC apps a spin; Once you’ve passed the hurdle of setting stuff up, they offer much more interesting features than keyboard wedges.

With a working PC/SC reader, Rohos is what you want to log into Windows smartly and elegantly. That was your original goal I believe.

1 Like