Dumping iclass 2k issue

Hi, @NinjuhhNutz and @philidelphiaChickens , I saw you guys post solutions in the forum, and I tried to follow the solution.
I have an iclass 2k and using Proxmark3, here is the info :

I tried to do hf iclass dump --ki 0 and hf iclass dump --ki 2, still no luck.

In the end I tried the loclass attack, but it keeps timeout.
Then , I run hf iclass loclass --test to check any error, turns out “can’t find iclass_key,bin”

Do you guys have any solutions??Thank you Have a nice day!

Have you tried

hf iclass dump --ki 1
hf iclass dump --ki 3

You can check hf iClass managekeys -p to check for available key indexes (ki) to try with the above command, it’s just those 4 for me

I read that hf iclass dump --ki 1 and 3 1 can cause brick to keys. Is it true?? thats why i’m not sure to do that.

1 Like

I have never heard that personally, and I don’t see why those keys would be any more likely to cause issues than the other two, BUT:

It’s probably a pretty good idea to wait for someone else to chip in and confirm

I tried it out on the one iClass card I have this morning and none of the four passwords caused me any problems, so they at least aren’t universally damaging, though it’s not a very large sample size…