Flipper Zero Video Games Module under Xtreme FW

On seeing our resident AI post about the Flipper Zero Video Games Module I ordered one immediately. It arrived yesterday.
It doesn’t run under Xtreme FW. So I went to the I-want-to-be-ridiculed-and-kicked-hard-in-the-nuts-'coz-Imma-noob XFW discord server where I was told to install the dev build.
Response to my “Thank you, how do I do that?” was a link to a bunch of files and folders with no explanation of how to install them and my lowly status meant that I am reluctant to ask (nuts still recovering).
Has anyone here hooked up the Video Game Module under the Xtreme FW?


It’s a relatively straightforward process luckily (The dev build thing, I don’t have the game module)

For clarity sake since the link isn’t exactly right, you want the “build it yourself” section, a little up from where the link sets me at least

Also, I would imagine it would work on MacOS, but I make no promises


Thank you but the first thing I read there is:

Warning We will not give basic support for compiling in our server. This is intended for people that already know what they are doing!

and given that that definitely does not include me I’ll probably leave it until I can book a hand-holding session with my favourite IT guru - you!


I haven’t set it up, or even looked further into it since the “announcement”

I did get a youtube video suggestion pop up in my feed that i didn’t watch, so basically, i know fuck all and have done even less.

What I can do though is flick you some links that may have clues for you


More info (not watched yet, but hope they help)

It will be a bit of time before I commit to this mod, but rest assured, if / when I do, ill do a write up in the Projects category



I wouldn’t recommend going back to them and asking for help personally, but if you want to give it a try and ask any subsequent questions here, I’ll at least try to help address them

1 Like

I got it working without any problem.

Just installed the latest update of XFW (0053).
Then installed the video game module tool via flipper labs or the app.
Connect the video game module.
Go to the video game module tool under tools.
And run the install official firmware.

This is the way i did it. Now the flipper recognizes the videogame module without any problem.


A little progress: I discovered that the “No signal” message was caused by a faulty cable. I replaced it and, after doing all the phases that Viktor mentions above, I got this message:

Now I just have to figure out how to get the module to initialise without having to resort to reverting to the original FW.
Viktor, are you saying that your FW is the standard XFW or do you have the Dev Build?

1 Like

Is the game module in the “App store” ?

1 Like

No but it doesn’t need to be: the video module is installed on the flipper and the module is sending that message to the screen so the module is generating a signal.
The problem is that to initialise the module flipper wants to be updated to the latest original FW which I am reluctant to do because I want to stay with Xtreme.
But Viktor seems to have managed it so I just have to figure out what I’m doing differently.

1 Like

Hmmm, strange. It looks like your flipper is running an older version of XFW.
This is the version i’m running:

I updated my flipper recently via Flipper Xtreme Web-Updater .
Here you can see the firmware i’m running on the updater site:

You can check your firmware by going to the big “X” sign between your apps.


Strange. Like you I updated recently to 53. That’s why I thought you might have the dev build.

1 Like

Solved! I went rummaging around in the settings and came across this:

It was set to listen to “none”. I changed it to…

…and Hey presto! done!
All works fine under XFW-53 :sunglasses::+1:


Great to hear!
I started second guessing myself :slight_smile:
Never seen this setting before. Was it already turned off? Or had you turned it off for a reason?