Help! Computer Login

Finally have some time to mess with Rohos. I selected MiFare1k RFID as my selected method, and it reads my spark, but it is asking for a pin. What am I supposed to enter. I apologize, I am new to this.

I haven’t used Rohos, so @Rosco will be the ideal one to guide you, but in the interim

I would assume the PIN it is asking for will be your UD/NUID
A couple of things for you to try before Rosco or somebody else jumps in.

In the PIN field, scan your MiFare1k on your KBR1 reader if you have one
OR
Scan your MiFare1k with TagInfo to get the NUID and manually type this in.

I’m not sure if you are limited in characters, but you could possibly 2FA by scanning your Mifare 1k THEN your Spark ( Or vice versa obviously )

I hope this answers your question, as Clearly I am not familiar with Rohos, but worth a try.

If you get stuck, I will install and try on my computer and try to work it out for you
Good Luck

When I scanned my NExT, it didn’t end up asking for a pin, so I’m wondering if that has to do with a spark specific feature? Or maybe you had a different login method set up for your computer that is looking for that same pin number? I’m not sure, frankly. I would check my spark, but for some reason I can’t even get my ACR to pick it up.

Just press enter. It’s an extra pin number that’s recorded somewhere in the registry, that Rohos can ask you when you scan your chip.

I’ve had one install of Rohos where you absolutely had to use a pin for some reason. Maybe it was misinstalled or something. I just entered one zero and that was it: I’d scan the chip, enter “0” then ENTER. It was annoying though. But it’s only happened to one of my computers. I never found out why.

Also, come to think about it, I wonder if it needs a real M1k or if it can work with any old NFC UID: I’ve only ever used it with a M1k myself. I know it only uses the UID if you use it in “dumb” mode, but it has provisions to read M1k sectors if you set it to do it. Maybe that’s why it requires a pin.

I’ll have a look into it tomorrow. Right now I don’t have a Windows computer handy.

I setup the flexNExT as a mifare 1k in Rohos the other day, so I’m pretty sure it’s just an NFC UID

Ah, Sorry,maybe I misread your question,

Do you have a xM1 or FlexM1(gen1a or gen2) or xMT…
Or did you just choose MiFare1k RFID as your selected method and you are trying to use your Spark to login?
I assume Spark 2, SO I am just guessing here, The MiFare1k RFID may be looking for a 4byte or 7byte (N)UID, I think the Spark 2 has 8 byte UID so that COULD be your problem???

I’ll shut up now, rather than just guess my way through it…

Yeah, I tried nothing and 0 to no avail. I took a screen capture for more clarity. I do have the spark 2. I blurred it in the screen capture, but it says Key MiFare-xxxxxxxxx has been found. the Xs are a 10 digit hexadecimal value. Here’s the link to the screen capture. https://www.youtube.com/watch?v=pbOG9b3nfoQ

Any of the collective wisdom is greatly appreciated!

Other than the above, what other options do you have?

image

Oops, forgot to include that! Here ya go!

Sorry if this is sucking eggs, but have you tried?

Yeah, It says “Wrong PIN. Please note that you have only 3 attempts to enter valid PIN.” It says that no matter what I enter

Had the same problem.

You’re right in selecting the Mifare.
Once selected, you can enter the Mifare-menu by clicking on the cog wheel (i think). There you will find an option “suppress PIN” or something similar, which you should activate. After that, no more requirement for the PIN :slightly_smiling_face:

Sorry for the vague description, i don’t have access to my PC right now. Hope it helps anyway :wink:

1 Like

That’s it! Thank you so much. It’s “Treat cards in ID-only mode”image

3 Likes

Yup, that’s the one! I was pretty far off, but hey! You got it to work :smiley:

And just in case you want to get rid of the annoying beeps of your ACR122, the screws to open it are under the padded feet :wink:

1 Like