Help unbricking T55xx Ring

I have the Magic ring. I cloned a HID Proxcard II card to the ring and used it for several months. Today, the ring stopped responding to readers. No beep, no click. no write on proxmark. Nothing.

There are some scuffs visually, but I don’t know whether something is just corrupted or actually broken. To my knowledge, I have not physically damaged it or handled it too roughly When I use lf tune in pm3, the voltage drops, so I can tell that its coupling from 25 to as low as 17 if I get the positioning right. From the combined sources of this forum, Iceman’s forum and the RRG Github, I have tried:
lf t55 detect
lf t55 wipe
some password fuckery that is supposed to fix it below
lf t55 write -b 0 -d 000c8040 --pwd 00000000
lf t55 write -b 0 -d 00148040 --pwd 00000000
lf t55xx write -b 0 -d 000880E8 -p 00000000
all of the commands on Amal’s unbricking the T5577 page.
lf tune
writing a password to block 0
wiping the password off block 0
Additionally, when I perform lf search, it leads to an error when checking COTAG and says that there are no LF 125khz tag present, which I know is not true because I know it is coupling.
When I perform the lf t55 dump command, it dumps empty lines with no hex characters and no output – I’m not even sure if it is reading the card at all.
When I try the lf t55 detect, it errors out and asks for me to run a config, which I do. It lists block 0 as 00000000 (n/a) which has been unaffected by all of my efforts to rewrite it.

Is there anything obvious that I am missing? The past several hours have been a Proxmark deep dive for me as well. I am running fully updated Iceman both PM3 and client.

I have ordered a replacement ring from you guys but I want to see if I can fix this before I write to my new ring coming soon.

mate, that is certainly an odd one, especially going from working to simply not.

I think you have done some great fault finding, the only thing extra I can think of is maybe trying to write something else to it, like

lf em 410x clone --id 0102030405

1 Like

Every lf search, I get this error

for lf t55 dump i get nothing

when i try detect and dump

when i do get it to couple - additionally, if I have the Proxmark scream write commands at it, it seems like its fine but no response on lf search

Ruling out physical defects makes sense, but consider the following will also silently damage RFID:

  • High heat, like being left in a car
  • Water with salt, sweat, or minerals
  • Radiation, like microwaves
  • Static electricity (electrostatic discharge, walk across carpet, light switch)

That is very possible. I tend to wear my ring all the time when doing anything so it wouldn’t be out of question for it to be exposed to a lot of that and cause damage. I did buy a new one and am trying to practice programming some T55xx cards with the pm3 so I can get a good clean write next time.

I also am reading the data sheet for the T55 and hope I did not accidentally lock my ring because I know something fucky is going on with block 0 cuz I cannot get a dump that has actual data.

I did have another pm3 question. I have a T55xx card that I tried to write a HID card to, just prox, and it wrote it as an Indala card with an odd number of bits showing on LF search. It does not show as a t55 and I have tried wiping the indala config off it, to no avail. Running LF t55xx config on FSK, ASK and PSK does not seem to affect it. I was trying different modulations to see if the Indala encoding would respond, which it did not. I can dump the data, with block 0 on page 1 showing 7 and a lot of Fs. I’ll snag screenshots when I have my pm3 available. What do you guys make of this.

Chances are the HID did not correctly write and you are just seeing random noise that is being displayed as Indala… you can confirm this by doing multiple consecutive searches and the data being returned is probably changing each time. That means it’s just noise. This is a failure of the Indala encoding mechanism for not having any real way to do error detection.

If that is case, how do I reverse this and return it to a writable state?

Also, thank you Amal for your awesome stuff. I need my RF magic back. :slight_smile:

1 Like

I would basically attempt to blast write commands at it until it submits to your will :wink:

If that doesn’t work there are a series of diagnostic methods to employ. Is it responding to lf t5 detect?

I will try to keep blasting it. Should I keep using the LF hid clone commands or other ones. No it does not respond to t55 detect nor does config actually seem to config it.

When I do an LF Search, it shows up as the fake Indala card with no card config detected, which is where it would normally suggest a T55xx

Hmm ok might need some recovery attempts…

1 Like

So I did the steps. It detects it as a t55 in p1, but the funky Indala encoding remains and is not detected with the norma t55 detect

You were right in that it shows as random data sometimes as a Keri tag too.
Also sometimes it will or will not pick it up as a t55xx, heavily depending on placement on Proxmark.
I tried the recoverpw tool in the t55 command which failed but suggested possible passwords.
Should I try LF detect with those possible passwords?
I will link dump data in another photo

I fucked around and the
Lf t55xx write -b 0 -d 000880E8 -p 00000000
Worked to unfuck the card
Completed a successful HID prox clone and tested so now both of my T55 cards are back in business
I tested my ring again
The voltage drop I saw in the LF tune for my ring is not the ring but my skin bridging contact between 2 screws on the Proxmark causing a volt drop.
With that finding, I rubbed the ring around the Proxmark in all kinds of orientations and nothing
I think the LF coil is probably just dead from some other factors that other posters mentioned. I should be getting my new ring tomorrow or Tuesday so I should be able to just write the blank t55 on the new one and I also know how to unfuck it now.
Thank you Amal and cyborg bros for all your help.

I know that there is still much for me to learn about the Proxmark and RF in general and I thank y’all for being such a great resource, perhaps the reason that I love this stuff so much.


UPDATE: I received my new ring a couple days ago.

Before writing to it, I checked the chip with T55xx detect and it detected it as a normal, blank T5 card. This is good. I also checked the lf tune to make sure that it is coupling before write. Small volt drop but not unusual for such a small device.

A quick lf hid clone and I am back in business.