I can´t write my xDF2 DESFire EV2 8kB NFC with my iphone. HELP PLEASE!

Good morning, I recently bought the xDF2 DESFire EV2 8kB NFC, my iphone x (ios 15) reads it to me but it does not let me write, I have tried with the recommended classic apps and I have tried to format it with the MIFARE® DESFire application and apparently it performs but still won’t let me write the chip. someone help me? greetings thank you

Hello,

Did you install the implant, or is it still in the syringe? The metal blocks most of the field.

If it’s installed, how long has it been? It can take a week or more for the swelling to go down enough for you to get good coupling. Reading a chip is much less energy intensive than writing to it, so you’ll have to wait longer to write.

My recommendation is to stop messing with it. DESFire chips are pretty robust against data tearing, but if you somehow misconfigure it while you’re frantically attempting poorly coupled write operations you may have to learn more than you bargained for about how to reconfigure it.

Also, it’s always a good idea to try new complicated operations on a test card, before moving to your implant.

2 Likes

Thanks for the prompt response, I have it implanted, the chip recognizes it without problems (I implanted it 1 week ago) but it does not write, it does not save the information. It will be a matter of waiting or I must take a step that I am not doing. Greetings and grace

1 Like

Okay, you should be able to write after a week. There’s an important difference between the xDF2 and the NExT that is preventing you from using it out of the box.

The NExT has all of its memory formatted as NDEF by default, which is what phones read when they open websites and such from a tag. The xDF2 is a more advanced chip that has a file structure and can be used for lots more stuff. You can just format it as a big NDEF container, which is what most people do. You just have to use specific apps to do the initial setup.

The one I recommend is provided by the manufacturer: TagWriter by NXP

Unfortunately I only have an Android, so I’ll share screenshots on that version of the app and you can figure it out on yours.

4 Likes

I had to use an Android phone to create the NDEF container.

Just wrote the first message with the Android phone and everything was fine on my iPhone after that.

3 Likes

I was afraid it would be something related to the iphone. I’ll get an android to test and I’ll tell you. Thanks both for your answers!

2 Likes

Good morning, I tried it with an android and the nxp app and I keep getting an error when trying to format the chip. It reads me perfectly but it does NOT let me write or format it (using iphone and android). I have tried both formatting options. Any advice? thank you! 1


![tempImagebY0DG0|375x500](upload://mu

051Vs4d4jjRjdOTupiFpcDp3P.jpeg)

Can you scan with TagInfo and post the full scan data file?

1 Like



THANK YOU for the help

I have no idea why it’s not provisioning because it has the default master key… but it also has a very odd AID of 0x000000 loaded… have you exposed this chip to any readers or really anything except your phone before?

You might try NFC tools to write a simple text record or something to a chip… It should format it first as part of that process.