Issue with RFID Implant: Unable to Read - NDEF Data Corruption?

Hey everyone,

I hope you’re all doing well. I’m reaching out to the community because I’ve encountered a rather perplexing issue with my RFID implant, and I was hoping to get some insights or advice on how to potentially resolve it.

So here’s the situation: I have an RFID implant that I’ve been using for a while without any major problems. However, recently I’ve been unable to read the data from the implant. Now, before jumping to conclusions, I don’t think it’s a hardware problem, as the LED indicator on the implant is still lighting up when I try to scan it. This leads me to suspect that the issue might lie within the NDEF.

I’ve considered the possibility that the NDEF data might have gotten corrupted somehow. To tackle this, I’ve attempted various approaches, but with limited success. Unfortunately, I don’t have access to a Proxmark or a compatible locking system, which could potentially help in diagnosing or resolving the issue. Instead, I’ve tried using three different Android smartphones to scan the implant, hoping that one of them might be able to detect and possibly correct any NDEF corruption.

Just to clarify, I haven’t locked the chip, so that shouldn’t be a contributing factor to the problem.

I’m really at a loss here, and I’m hoping that some of you might have encountered similar situations. If you have any suggestions, insights, or even alternative methods I could try to address this issue, I would be incredibly grateful.

Thanks in advance for your time and assistance!

Implant: xSIID - NFC+LED

Best regards,

1 Like

me also, as it sounds like you know what you are doing.
You said that you have had it a while, could you put an approximate time period on that.
Are we talking weeks, months, years?

Have you enrolled it to any readers? if so, do they react to your xSIID?

Trying 3 android phones with no success, does sound data or hardware related.

I think there is still a possibility of a hardware issue, and it may be just a matter of time before the LED goes also.

Let’s hope it is data related, although
It would be weird for it to just stop working with no interaction to corrupt it.

I’ll find you something to try ( it still may not work if you can’t communicate with it. )
wait one…

1 Like

Download this app if you don’t already have it

Follow Devs instructions in the following post

let us know how you go


Around 9 Months i think.

I haven’t been able to do that yet as I don’t have an external reader. I’m considering getting a Proxmark for this purpose, especially given the current circumstances.

Thank you, I will give that a try and will get back to you. Unfortunately, the NFC Shell app is considered too outdated for my Android version according to the Play Store. I will attempt this using NFC Tools instead.


You can bypass googles authentication and install the apk directly from the deveopers page:


I have now tried it with NFC Tools and also with NFC Shell on one adroid device. Sadly, both programs don’t seem to recognize my chip.

Were you previously able to get a read on the same android devices? I just wonder if you are having trouble getting the sweet spot. I had that happen once where i couldn’t get a read on an android device and realised after 24 hours i was using a different phone with the sweet spot in a different place to my other phone.


There are also “adaptive” power saving features in Android now that apparently diminish the power output of wifi, bluetooth, and NFC… plug in the phone to a charger and let it charge up a bit, then try reading… remove any cases, etc.

It might be possible the ndef record became corrupted on a recent write attempt so that could be the issue… an ACR122U or similar reader that simply beeps when it selects the ISO14443A tag in the field and doesn’t try to read any memory could be a good indicator that it has something to do with the ndef / user memory and not an issue with the transponder itself… but yeah phones are going to try to do all kinda of interrogation of the tag before it hands off any control to the app that’s trying to talk to the tag, be it nfc tools or tagwriter… and if the memory is corrupted in just the right way, the OS will bork and the tag event / object will never get passed over to the app… so it just looks like it’s not being read.

1 Like

@hadoukenboy628 Yes :slight_smile:

That’s a good point. However, while I was trying that, my device’s battery was at 70-90%. And I’m not the type to use a case.

I will give this a try and will get back in touch. Thanks.
But I need to order it first, which might take a bit of time…

Which country are you if you don’t me asking?

I’m from Germany.

Ah okay. If we were same country as me i would try and get a card reader to you. :slightly_frowning_face:

@hadoukenboy628 This would be great thank you for you offer :slight_smile:

It arrived! And it is beeping!

1 Like

Do you hav some recommendations for a program on Windows or Mac? I tried to run the commands @Pilgrimsmaster recommended with NFCtools for desktop but ERROR occurred.

What reader are you using

ACR122U ?


When you say it beeps you mean we th a different tag or with your implant?

with my implant

Okay. A few follow up questions:

What is with the reader plugged into a computer or with otg on the mobile?

What colour is the reader flashing when you hear the beep?

Do you have any apps / programs open when it makes the beep or are you just tapping from the desktop?