KBR1 needing to be replugged after shutting down

Hello!

I’m new here and just got the NExT implant a few days ago and have been loving the KBR1 for quick login to my computer. However, I’ve noticed that whenever I shut down my computer (I’m on Windows 10 btw) and turn it back on, the KBR1 displays the red LED and beeps when I scan my implant, but doesn’t spit out the UID. Upon unplugging and plugging it back in, it will work normally.

Also, when I restart my computer it works just fine, I only run into the issue when I shut down my computer.

I’ve tried switching ports and using USB 3.0 / USB 2.0 ports with no luck. I’ve also made sure to disable the USB selective suspend setting in the power options.

Any help is appreciated, and I’m glad to finally join the community!

Odd… sounds like the human interface driver isn’t recognizing it… when it’s beeping but not working, what does device manager say? Any errors on driver load?

I’m looking in device manager under Human Interface Devices, but I am not seeing any errors on the devices listed… Though after looking at the events of some of the USB Input devices it says “device not migrated”, not sure if that helps.

Shut down completely or suspend?

I press the shut down button in the windows power menu, I believe it’s a full shut down.

It it’s a laptop, possibly not. It might be suspending to disk. Although you’d notice: you’d get the session back as you left it. So I guess my question was silly.

Look in the BIOS settings: sometimes you find “legacy USB” options or some such there. Also, if you’re not interested in charging stuff when the computer is off, sometimes there are also options to power down the USB sockets when the machine is off - which would power down the KBR1 and force a re-enumeration at the next bootup.

Just did a little bit of research, apparently the windows shut down button actually puts it into a “hibernate” mode instead of fully shutting down… Anyways, I shall go look at my BIOS settings as you’ve noted. Also if it helps I am on a desktop not laptop.

Okay so if it hibernates, then it’s a classic case of Windows not re-enumerating the USB devices upon restart. Look around in the driver settings, and in the power management settings: you might find stuff there too.

Or you could just, you know, shut it down for real :slight_smile:

So after looking in the BIOS settings I did not find anything about legacy USB, but when I looked at the power options in control panel, I was able to disable the hibernate mode by turning off fast startup! Now when I shut down my computer it actually shuts down and the KBR1 works!

Thank you so much for your help!

3 Likes

You bet!

1 Like