KBR1 Not Working on Windows 10

Hello, I’m trying to use kbr1 keyboard wedger on my windows 10 pc but it doesn’t detect it and kbr1 is constantly beeping, I tried all the solutions : unplugged other usb ports, updated windows, changed power settings etc… but none of it solved the problem. Windows doesn’t even show kbr1 in device manager, however when I switch to Arch Linux it works just fine so this is not a hardware problem it also works fine with my windows server 2016 machine. Can anybody help me with this problem?

Windows 10 Version info :

Screenshot_8

1 Like

Since it works with another operating system but not your Windows 10 setup, I have to think that there is something going on with the power settings at a deeper level. What about checking the bios for low power mode settings? Or maybe post some screenshots of this settings you’re changing in Windows 10?

Oh also, is this a laptop or a desktop?

Have you tried putting a powered USB hub between the computer and the KBR1? That’s another way to sort of offset any system-based power settings that might be affecting the KBR1.

Clearly the solution here is to ditch Windows and keep running Linux :slight_smile:

2 Likes

Thank you for your answer, I’m using desktop amd b550 chipset, updated my bios to latest beta and changed all usb settings on the bios I can find but none makes difference. I changed windows power settings as well including :

Screenshot_2

Still doesn’t detect :face_with_monocle: I don’t have a usb hub but if I find one i will try.

@anon3825968 Already using linux daily but it’s cool to login to windows quickly before gaming :joy:

1 Like

So I figured out that the cause of this problem is amd usb 3.10 extensible host controller which controls usb devices on amd systems, it has compatibility issues and when I delete them from device manager kbr1 works but other usb devices disconnects and when I reboot amd usb 3.10 extensible host controller gets installed again and kbr1 stops working. Interesting… :thinking:

Screenshot_9

I came across another person with the exact same issue but he’s using an razer Deathadder mouse, his youtube video :

2 Likes

I’m having this same issue, tried all the same stuff as you tried too. Hopefully one of us can figure out a way to resolve the issue. :slight_smile:

1 Like

Has anyone managed to find a workaround for this issue? Or is using a powered USB hub the best current workaround? Just got my KBR1 in the mail today and i’m experiencing the same issue. The KBR1 beeps continuously but doesn’t show up as an input device. I’m on a desktop with an AMD X570 chipset. Any input/advice would be appreciated.

1 Like

I’d try it in a different computer. I did with mine & it only beeped once, then showed up in the devices.

It seems to be an issue with certain computers, that even if you adjust the settings to make it work, the computer still wont output the necessary amount of power for it.

Someone suggested a multiport usb device, if I recall correctly. So that might work. (I ended up just using a different computer since I had the parts around to do that.)

1 Like

I ended up getting the cheapest powered usb hub i could and connecting the KBR1 through that. It’s working perfectly now.

4 Likes