Magic ring V2 sudden range issue

The magic ring v2 worked great for two weeks. I could keep it on my finger and open my safe without even touching my hand. Suddenly the ring needs to be removed and physically touching the safe to activate. Initially I assumed the receiver was failing so I grabbed several other RFID, tags all of them worked fine. It’s only the v2 ring that’s failing. My old v1 ring (that no longer fits my finger) works perfectly even after several years, my newest v1 that’s a year old quit working on me so I upgraded to the much nicer v2. But something is wrong with this’s v2 ring.

I had an old jakr4 ring that the ceramic got chipped and water killed it. This v2 ring isn’t chipped but I wear it in the shower. If water was to get inside would that degrade the signal or kill it like it did with the jakr4?

Seems a bit strange, just like the other thread you mentioned, with both of you experiencing the same thing.

You might be onto something with the potential water damage.

If Amal has seen this post, I imagine he is doing some literal soak tests to try and replicate your issue

I’m definitely interested in getting these rings back for testing. The first thing I’m going to do is put them in a warm vacuum chamber to see if I can dry them out… or basically see if I can improve range by doing that which would indicate their was probably water that got inside.

1 Like

I’m the guy from YouTube that was chatting with you briefly. I no longer have the purchase email, I have the original black box though the ring came in. If you tell me where to send it I’ll gladly ship it back to see if it qualifies for a warranty.

The safe is a Hornady and the two magic v1 rings worked flawlessly for years. One is no longer working. So I upgraded to the magic v2 and that worked for about two weeks. Now it needs to be pressed to the receiver to activate. I thought maybe the receiver was going bad but the ring id the only RFID tag that’s not working properly I have several others, including a magic v1 that still works fine. I wear it in the shower sometimes.

I’m wondering if a bit of moister got inside and cause the ring to corrode a little causing a weak signal. Either that or the antenna is dying for someone. I do use the ring 2 times daily at a minimum.

hit the orange help button and submit this thread with a warranty replacement request. be sure to use the same email you used to order with so we can try to match up your order

1 Like

Honestly, I’ve used that orange button for this same problem 3 times over the last week. Still zero response I’ve referenced this thread the last time.

I’m not a huge customer but I’ve ordered three rings over the last couple of years. With this ring being defective and me learning how hard it is to communicate with your company it almost makes me want to just move on.

I’m not a really knowledgeable in the RFID arena but I do technical diagnostics five days a week for a living. I’m not an idiot, this ring is defective and all I want is to swap it out and move on.

Sure I’m coming off as a jerk right now but I’m just frustrated with the horrible communication process. One of which doesn’t seem to be working, the orange help button.

Sorry I’m not the guy that keeps emails, my wife claims I’m OCD. Us computer guys just know some of us delete everything and some of us delete nothing. Personally I think the latter is just lazy.

2 Likes

i only see one ticket for you, and since we don’t have your order number i will need to look it up and get your replacement ready. the earliest i can do that is Monday.

1 Like

No problem, thank you.

I’m having the exact same issue, I only use my ring every few weeks, so it took me a while to notice. I can’t write to the rfid without taking the ring off and placing it on the reader. I basically can’t get the NFC to read at all anymore.

I’m back to rocking my ringV1 for now.

I tried to call the front page “contact us” number, but only got voicemail.

Try the help button
:help:

Bottom right of the web page.

It will generate a tick in the DT system.

You should be able to share your forum post to accompany your Ticket

https://forum.dangerousthings.com/t/magic-ring-v2-sudden-range-issue/21184/9?u=pilgrimsmaster

I got a replacement under warranty, the warranty process was so dang long and terrible that i haven’t even started it on my second ring that is doing the exact same thing.

So from what i know between me you and another member that’s a total of 4 rings with the exact same issue.

I wonder what the cause is. Ive had two v1 rings with zero issues. I have had two v2 rings now and both start out great and lose range in a few weeks.

My v2 ring is having issues with its range. I put the ring in a gun safe that has a moisture removing device (brain dead right now) and after 4 days the range seemed to be better. I personally think this is a moisture issue.

This seems to be inline with some of the performance issues some rings experience over time. We are working with the factory to see if we can resolve the problem before ordering a new run.

2 Likes