My xSIID implant adds garbage characters to the URLs

Hello everyone, I’m writing in search of help with a problem my implant is presenting.

The problem began when I couldn’t write with NFC Tools anymore, so I carried out the procedure described here (which involves using the NFC Shell application to load a URL using hexadecimal):


After this, the implant worked normally again, but with a problem when writing URLs since as can be seen in the images, garbage characters are added to the end of each loaded URL.

At first, I thought it could be an error with the NFC Tools application, so I also used TagWriter and obtained the same result with both applications. Additionally, I used the “erase tag” option, but this didn’t work either.

Furthermore, to rule out a problem with any character in the URL, I loaded the same URL on another NFC tag and it worked properly.

Does anyone know how to fix this error? Thank you very much in advance.

This is the uploaded url:


But actually the loaded URL is this:

Hmm. Well, I don’t believe this is even something the ntag i2c chip in the xSIID can even do to be honest.

How many different urls and tests have you tried on it? Can you post information about those tests?

Purely out of curiosity, does garbage get added when writing other data types as well, or is it just with URLs? What happens if you try to write text to it?

It’s curious, it works perfectly on Android and opens the URL without a problem, but on iPhone (iOS) the URL that the browser opens is “the URL with garbage”. Is there a way to perform a factory reset on the implant? since the problem started when I used NFC Shell on Android.

I have also noticed that the “garbage” attached to the URL is not random, but at a certain point, it begins to repeat part of the same URL. For example:

In the images, you can see how the URL is cut off when trying to write “index.html” and writes “index.h/mo” instead. Instead of writing “tml”, it writes “/mo”, which indicates that the URL begins to repeat from “/modules”

1 Like

Yes, the same thing happens when writing information in plain text

this is what i try to write:


but what is actually stored is this:


As you can see, not even the complete information is stored, the message is truncated and the “garbage” that is added at the end is part of the same message.

full dump pls?