New Proxmark 3 Easy possibly bricked

Serious question because I had issues

Have you tried a different cable?

At some point in the beginning of my prox journey I had a power only micro usb cable, no data

That caused some headache

This post where you solved it :+1:


1 Like

I’m not sure if this has been solved yet or not, but which port on the proxmark are you playing into? There are 2. One on the side and one on the top near the LEDs. The top one is what you use. The side one is for powering headless operation.


Use the USB port on the short side of the pm3

Sorry guys for the late update - had something come up for the last few hours.

I tried Edge and Opera earlier with the same error. In the end I just googled the ‘home page’ if you will and registered on there and it worked. Seems like I can’t access any of the posts though, just a message that says change with the times and gives you the PM discord anyway.

I ended up fluking it earlier by holding the button down whilst plugging in the proxmark.

It shows up after a few seconds and actually works without holding the button down every time after that. Works the same way on both computers too.

I ended up tinkering for about 2 hours trying to wrap my head around setting up the dependencies on Windows 10. I was following this video and after doing


the command seemed to have worked. Comparing the text in the video vs. the one on my cmd prompt. When I tried to move onto the next step however, it says

[=] Waiting for Proxmark3 to appear…

That’s when I realized I got these…
pm3-devdescreqfailed pm3-notrecog

Since then, its been the same error on both computers again.

Any ideas?

All the LEDs on the PM3 Easy are lit up. :confused:
did i brick it? :cry:

That was in one of the links sent you…

Did you follow the other link I gave you with @anon2520759 step by step guide?

If this is the case, I only know of one other person who managed this and yes it was bricked needed to be replaced via jtag / external programmer.

Probably would have been worth using either precompiled via @anon2520759 guide or fully understood what you where doing first :sweat_smile:

There’s a couple guides out there on how to unbrick the thing (I’ve never done it) maybe check out the proxmark forums and discord?

1 Like

Might I ask how exactly it was bricked? My PM3 arrives today, I’d rather not brick it right out the gate

I did it before I read your reply - sorry.

so I apologize to everyone who responded to my thread. I was quite tired yesterday from working on other things and really shouldn’t have tried to mess with it.

In order to do my part and help @DonFire as well I’m going to go through what I did yesterday and what I found out…

When I initially tried to use the proxmark, I followed instructions from the PM3 GitHub Wiki Here. This for reasons I can’t quite remember did not work (It’s been hours and I didn’t dive into it). Something about it not being able to find the correct directory, I think.

This is when I just started doing a lot of random googling to see if I can find some dumbed down instructions for a newbie, instructions that simply told you what to do or even what to click/type in without using fancy technical terms.

Do please try to understand, I knew what I was getting into, jumping straight to the Proxmark instead of experimenting with say, a blue cloner. However, it was other enthusiasts who recommended against getting Blue Cloners, and there isn’t really any choice in between. There wasn’t a single statement mentioning which specific guide to use. Googling ‘proxmark 3 manual’ or similar terms simply leads to any of the various forks on GitHub.

The key thing is that from the perspective of a newbie reading Wikis on GitHub, you get the impression that you must compile everything yourself and flash the PM3 Easy with latest versions before you can use it.

Anyway, through corroborating the different links and videos I’ve gathered from people, I think I’ve finally come up with some instructions that I should’ve followed. Please correct me if I’m wrong!

  1. I should be going HERE and not anywhere else. It’s clear to me what ‘Precompiled Windows Binaries’ means now. I’m thinking of it like a simple Proxmark3.exe file with all the dependencies it needs within the folders ready to go. I have a choice to either download the 2020-09-24 release or the latest one. It means I can skip everything I saw on the github wikis about git cloning + making + compiling from the repos.

  2. Reboot into driver signature disabled mode & install drivers.

  3. If I chose to download the latest version and update the proxmark myself, then I edit FLASH - All.bat and change the COM port to the correct one for my machine.

  4. Hold the button down and run FLASH - All.bat until completion. Never let go of the button

  5. Upon completion, release button, disconnect, and reconnect.

  6. Run ‘proxmark3.exe COMX’ (where X is my COM port number)

From what I can gather, this is simply all that needs to be done in order to run the PM3 Easy. In fact, if I chose not to update, I can download the identical 2020-09-24 release, install the drivers and simply go straight to Step 6 and run proxmark3.exe.

Again, please correct me if I’m wrong.

Honestly, it didn’t even seem like I did anything wrong. I was following some wiki and the command prompt told me ‘Have a nice day’ or something along those lines. Video guides and some websites told me if I got to that step everything should’ve been fine. It wasn’t until I tried to actually run proxmark3.exe I think that I realized windows 10 wasn’t detecting the device properly.

Anyways, I’d say wait until someone else can proof read my new set of simplified + dumbed down set of instructions above before actually experimenting if you’re like me completely new to the proxmark.

Didn’t realise the forum link wasn’t working, have added a comment to that guide with the new links (including 32bit for anyone who uses that). Your dumbed down steps are pretty much the same as my guide, just less words :wink:

It definitely isn’t newb friendly, I had a lot of issues getting it set up too. Compiling on Windows 10 just didn’t want to work for me at all, and now that I’ve seen the solution to my issue - there was no way in hell I would have fixed it without someone guiding me through it live.

And yes, that’s correct; if you didn’t want to update the firmware and just get it running, you just need the identical client version for the firmware that is on the PM3. If there’s a version mismatch it won’t communicate with the PM3 which is important for anyone else who may be new to know.

Words are hard! I never thought I’d be dyslexic but now I’m beginning to think im just undiagnosed, LOL.

Thats the thing, at the end of the day people on forums are just voluntarily helping others. On the flip side, DT is a vendor and I do feel like they should have some kind of dedicated customer service whenever thats possible for them in the future. I spent over $500 USD on my first ever purchase with them and somehow I feel bad emailing them directly and getting @amal to help me.

So are you saying that if I tried to run

proxmark3.exe COMX

It would error out? and simply not let me continue?

The good news is I managed to find a place called Everything ID here in Australia that are currently trying to ask their tech team if it’ll be possible for me to just pay a little bit for their time and help me unbrick it, rather than having to send this back to the USA.

They also sell a Proxmark 3 Easy themselves so its giving me some hope.

DT’s customer service is amazing, really. But for something like this which is pretty niche, I don’t think it should fall on them to help guide people through the process. It’s a notoriously unfriendly device for new users :joy: but the forum is here, the DT discord and also the proxmark forums (though, they can seem unfriendly to people who are completely new to all this).

That being said though, I was new to it all too… I had no idea what I was doing, thus why I was stumped when following the official wiki guide didn’t work. But lots of research and reading helped me figure it out and it was a good learning experience in the end.

If your client/software version is different to the PM3 firmware, it’ll just tell you it’s unable to communicate with the proxmark. It’s a pretty common error which is why it’s often a good idea to keep it updated - probably less of an issue if you don’t use git though.

Iceman’s discord may be able to help you too, possibly even people on the DT Discord but it all depends who is on at what time and who has the time.

Unfortunately your issue is a bit beyond me, but I hope you can get it fixed soon. I was this close to buying a JTAG thinking I’d bricked mine.

1 Like

they do actually - you just rely to your order confirmation email. The bigger issue is that it is a niche product as @anon2520759 said - Michelle can only do so much remotely, and same with Amal.

Ultimately, that software wasn’t written by or for DT, and iceman, who is the main author, did much / all of it for free, and still does volunteer his time. If you want personal email support you can become a patreon of his at a high enough level.

The PM3 is first and foremost a research tool, and as a chinese clone, and yes, it has its drawbacks. I hope you get it working!

1 Like

Dev may be right here, but we can try some things…

The first thing you should do is remove any and all drivers you may have installed to operate your proxmark3 from Windows… yank 'em out.

The next thing you need to do is see if your proxmark3 is responding at all as a virtual com port when the button is held down during boot… if so then you may have a way out. To test this, open the device manager and expand Ports and watch as you hold the one and only button down while plugging in your pm3 to USB, and then keep holding it down for at least 10 seconds.

I personally use this switchable USB cable for making quick connect / disconnect easier with USB devices…

If you see a new COM device show up in your device manager under Ports then you have a chance. Next you need to set up ProxSpace so you can pull down and compile the latest RRG / Iceman firmware. Follow the steps in this thread to set up ProxSpace, get the firmware source code, and compile it.

Once you have the compiled firmware, deploying it to the pm3 will require some fancy button work, but it should be possible if you can see a COM port show up when holding down the button and connecting the USB cable.

(have been helping @StrwbrrySam in PM / discord PM)
unfortunately his bootlooader does not respond / work. it just shows usb device was not recognised.

I bricked my pm3 easy to the same state on purpose and then fixed it using jtag as a test, we are now waiting on his order of required jtag equipment (we’re using RPi currently).

I’m in the middle of writing up a guide on un-bricking using jtag, should be up soon under dt info / wikis for others to follow!


Hey @DonFire,

You’re a good cunt :+1:


why thanks you! Hopefully very few people need it, but if they do it’ll be there