New Proxmark 3 Easy possibly bricked

Hello everyone, hope you’re all doing okay.

So I’ve just received a care package with all my implants and the PM3 Easy. I won’t be able to install my implants yet (local piercing studios booked out for 2 weeks), but I thought I’d play with the PM3 Easy and the included testing cards and fobs so I’d be ready for when my implants are installed.

Long story short, I’ve been unable to get started with the PM3 Easy. That’s literally all I can say to describe the issue.

My first question is, is there a main thread or primary website I should be looking for on documentation regarding the PM3 Easy? I don’t yet know enough to tell the difference between different Proxmark iterations and firmware versions/forks etc, and instructions seem to differ across different vendors that sell proxmark hardware.

Wherever I look however, the instructions tell me to plug in the PM3 Easy first and look for a device under ‘Ports’ but its not even showing up in device manager for me. I’m using the cable that’s included and I’ve tried every port on my PC as well as my laptop. It doesn’t show up on either device.

May I get a dummy-proof guide from someone on how to get started? I’m currently recording every step of my experience in getting implants and I’m hoping to condense all the up-to-date information into a video and post it somewhere, hopefully save someone else the headache of trying to dig through forums and stuff.

Thanks for your time!

If you got the Proxmark Easy from DT, it will be an Iceman / RRG 2020-09-24 release

So I am assuming Windows 10?

Try this excellent guide created by @ithritin

There are a few places we could send you, but we should be able to help you out here.

That would be fantastic

Don’t forget to send some love @ithritin way, if the guide works out for you.

Good luck,

1 Like

image

I get this when trying to register for the proxmark forum :frowning:

Also, I’m already in the ‘Disable driver signature enforcement’ mode and tried plugging in the Proxmark but Device Manager still doesn’t show anything…

There aren’t even any sounds coming from windows to show that it detects hardware being plugged in. The white Power LED is on, as well as green 0A and orange 0C.

Have a quick look at this, and see if it helps

Have you tried the RFID Discord
Just make sure you do your due diligence BEFORE asking questions
Here is an Invite

What browsers have you tried?

I just tried with:
Chrome
IE
Edge
and they worked fine

Duck Duck Go DID NOT WORK ( Same error as you )

I can try Firefox for you also but that is on another computer
UPDATE
Just tried Firefox, and again no issue

Are you trying to reach the site through TOR?

Serious question because I had issues

Have you tried a different cable?

At some point in the beginning of my prox journey I had a power only micro usb cable, no data

That caused some headache

This post where you solved it :+1:

image

1 Like

I’m not sure if this has been solved yet or not, but which port on the proxmark are you playing into? There are 2. One on the side and one on the top near the LEDs. The top one is what you use. The side one is for powering headless operation.

1 Like

Use the USB port on the short side of the pm3

Sorry guys for the late update - had something come up for the last few hours.

I tried Edge and Opera earlier with the same error. In the end I just googled the ‘home page’ if you will and registered on there and it worked. Seems like I can’t access any of the posts though, just a message that says change with the times and gives you the PM discord anyway.

I ended up fluking it earlier by holding the button down whilst plugging in the proxmark.

It shows up after a few seconds and actually works without holding the button down every time after that. Works the same way on both computers too.

I ended up tinkering for about 2 hours trying to wrap my head around setting up the dependencies on Windows 10. I was following this video and after doing

./pm3-flash-all

the command seemed to have worked. Comparing the text in the video vs. the one on my cmd prompt. When I tried to move onto the next step however, it says

[=] Waiting for Proxmark3 to appear…

That’s when I realized I got these…
pm3-devdescreqfailed pm3-notrecog

Since then, its been the same error on both computers again.

Any ideas?

All the LEDs on the PM3 Easy are lit up. :confused:
did i brick it? :cry:

That was in one of the links sent you…

Did you follow the other link I gave you with @ithritin step by step guide?

If this is the case, I only know of one other person who managed this and yes it was bricked needed to be replaced via jtag / external programmer.

Probably would have been worth using either precompiled via @ithritin guide or fully understood what you where doing first :sweat_smile:

There’s a couple guides out there on how to unbrick the thing (I’ve never done it) maybe check out the proxmark forums and discord?

1 Like

Might I ask how exactly it was bricked? My PM3 arrives today, I’d rather not brick it right out the gate

I did it before I read your reply - sorry.

ANYWAY
so I apologize to everyone who responded to my thread. I was quite tired yesterday from working on other things and really shouldn’t have tried to mess with it.

In order to do my part and help @DonFire as well I’m going to go through what I did yesterday and what I found out…

When I initially tried to use the proxmark, I followed instructions from the PM3 GitHub Wiki Here. This for reasons I can’t quite remember did not work (It’s been hours and I didn’t dive into it). Something about it not being able to find the correct directory, I think.

This is when I just started doing a lot of random googling to see if I can find some dumbed down instructions for a newbie, instructions that simply told you what to do or even what to click/type in without using fancy technical terms.

Do please try to understand, I knew what I was getting into, jumping straight to the Proxmark instead of experimenting with say, a blue cloner. However, it was other enthusiasts who recommended against getting Blue Cloners, and there isn’t really any choice in between. There wasn’t a single statement mentioning which specific guide to use. Googling ‘proxmark 3 manual’ or similar terms simply leads to any of the various forks on GitHub.

The key thing is that from the perspective of a newbie reading Wikis on GitHub, you get the impression that you must compile everything yourself and flash the PM3 Easy with latest versions before you can use it.

Anyway, through corroborating the different links and videos I’ve gathered from people, I think I’ve finally come up with some instructions that I should’ve followed. Please correct me if I’m wrong!

  1. I should be going HERE and not anywhere else. It’s clear to me what ‘Precompiled Windows Binaries’ means now. I’m thinking of it like a simple Proxmark3.exe file with all the dependencies it needs within the folders ready to go. I have a choice to either download the 2020-09-24 release or the latest one. It means I can skip everything I saw on the github wikis about git cloning + making + compiling from the repos.

  2. Reboot into driver signature disabled mode & install drivers.

  3. If I chose to download the latest version and update the proxmark myself, then I edit FLASH - All.bat and change the COM port to the correct one for my machine.

  4. Hold the button down and run FLASH - All.bat until completion. Never let go of the button

  5. Upon completion, release button, disconnect, and reconnect.

  6. Run ‘proxmark3.exe COMX’ (where X is my COM port number)

From what I can gather, this is simply all that needs to be done in order to run the PM3 Easy. In fact, if I chose not to update, I can download the identical 2020-09-24 release, install the drivers and simply go straight to Step 6 and run proxmark3.exe.

Again, please correct me if I’m wrong.

Honestly, it didn’t even seem like I did anything wrong. I was following some wiki and the command prompt told me ‘Have a nice day’ or something along those lines. Video guides and some websites told me if I got to that step everything should’ve been fine. It wasn’t until I tried to actually run proxmark3.exe I think that I realized windows 10 wasn’t detecting the device properly.

Anyways, I’d say wait until someone else can proof read my new set of simplified + dumbed down set of instructions above before actually experimenting if you’re like me completely new to the proxmark.

Didn’t realise the forum link wasn’t working, have added a comment to that guide with the new links (including 32bit for anyone who uses that). Your dumbed down steps are pretty much the same as my guide, just less words :wink:

It definitely isn’t newb friendly, I had a lot of issues getting it set up too. Compiling on Windows 10 just didn’t want to work for me at all, and now that I’ve seen the solution to my issue - there was no way in hell I would have fixed it without someone guiding me through it live.

And yes, that’s correct; if you didn’t want to update the firmware and just get it running, you just need the identical client version for the firmware that is on the PM3. If there’s a version mismatch it won’t communicate with the PM3 which is important for anyone else who may be new to know.