New ring not reading on doors? Debug or return?

I recently got the NFC+5577 ring and I’m having difficulty with it - wonder what my options are or if I should attempt to return it?

NFC portion specifically.

Proxmark3 - reads fine instantly
Smartphone - intermittently reads
Door readers - no signs of reading at all (not even failed read, no lights at all)

I know its the right kind (MF Classic) because I have a wrist band that works fine on all of them.

1 Like

Have you copied a known good/enrolled uid and data sectors to the HF side of the ring? Some systems will not acknowledge a chip if it does not contain the proper information, thus it may not even react with a a beep or light change even the the chip has been read.

Also, if you can provide more info about the reader that you are trying to use, someone on the forum may have experience with it and be able to tell you where the sweet spot for reads is. The antenna on the ring is usually large enough that this doesn’t matter, but it can still apply in some cases.

1 Like

The readers have been at Hampton Inn hotels, its a small round or square pad on the wall or door, that’s all I know about it.

And I didn’t want to alter the programming of the ring until I tested it (return policy) but I could copy the ring preprogrammed default NFC data to a normal size card and it would beep and give a “denied” red blink so I think its a protocol/coupling issue rather than a code-validity issue.

OK, so the ring is working as it should on Proxmark and phone (albiet, you havent yet mastered the placement on your phone yet)

So far you haven’t written anything to it, you are just presenting it to the Hampton readers and getting no reactions!?

If your wrist band is the same (it may not quite be, I’ll explain shortly).
agreed with the code validity, as you haven’t written this to the ring yet.
So, my best guess here is the coupling, as seen with your phone intermittent reads; this is probably the best place to learn the sweetspot on the ring ( and phone , this may help you, WIKI - NFC phone performance ), when you have found this on your ring, you’ll wan’t to find the sweetspot on the reader And how best to present the ring eg. Swiping across the face of the reader and at what speed and angle etc.

As mentioned above, “If your wrist band is the same (it may not quite be,)”
The Magic Ring uses a gen2 MF1k Chip, MOST wrist bands etc you will find will be gen1a, This only really matter for 2 reasons ( VERY lose explaination below )

  • The process for writing
  • The process for Reading

For you and this example, the gen2 Ring is what we care about, there are SOME ( very few) readers that will check if the chip is a gen2 , and block access.

I think you need to check your wrist band that is seen but denied access to confirm if it is a gen1a or gen2; there are a couple of ways to do this, the easiest is probably using MCT

MCT with allow you to change the (N)UID on a gen2, like your ring, BUT NOT the (N)UID of a gen1a, like POSSIBLY your wrist band

I think we have narrowed down your problem to one of two things

  • Presentation / coupling issue ( What I think it is )
  • gen2 denial at reader ( unlikely, but a possibility )

I hope that helps you narrow down your issue, and gives you some fault finding solutions to try

Here is a far more thorough explaination about the different Magic MF1k chips

1 Like

Yes, because I didn’t want to violate the return policy that says you can’t return it if you change what’s on it. I’ve had some no-name china NFC ring that had a similar issue (hoped the DangerousThings one would do better) even writing to it wouldn’t read on the hotel readers. That’s why I went the direction of copying the ring to the gen1a card to try and tell what the hotel reader would behave for the default-factory programming on the ring to see “would this even be recognized” before altering it and being unable to return.

I’m familiar with the gen2 write process as the no-name one I’d previously tried was also a gen2 NFC-only ring (and I also never got it to successfully read on door/lock readers, same exact issue).

I’ve not found much for tips on presenting/coupling a ring (e.g. keep it on, take it off, hold it perpendicular, hold it parallel…I attempted to try all 4 combinations I could think of), but I would believe this is the issue. I know the wrist band (which is bigger) had to be EXACTLY the correct orientation and portion of the reader to work.

I’m not familiar with readers that could “identify” a gen2 copy and deny, but I have no idea how to tell if that’s the issue.

1 Like

I have no experience with the ring tag nor the Hampton hotel’s readers thus take my suggestions with a pinch of salt.

From general experience, readers at such establishments usually idle in an ‘ultra low power’ state and need to be ‘woken up’, which usually happens on presentation of a genuine card. I have a suspicion that the ring isn’t waking up the reader. Please try using the genuine card or any similar 13.56mhz card to wake up the redder then try the ring just after.

You may notice the LEDs will slightly brighten when woken up before it attempts to interact with the card.

Could you take a photo of the reader for further research?

1 Like

This is called card detection mode. For battery powered readers like those commonly used for hotel doors, this offers a way for the reader to not probe for legitimate transponders but put out a very weak signal and attempted to detect a significant power drain from a resonant transponder within the field. If detected, the field is powered up to full strength and the reader attempts to read the transponder.

Transponders with smaller antennas do not have the same quality factor when coupling to these readers as a full-size card or genuine fob might, therefore they have a hard time pulling enough power from the low power field to trigger detection and a full power read from the reader.

If you have an RDC you can attempt to put the card up to the reader first, then rapidly remove it and place the ring up to the reader. The RDC card should couple well enough to pull an appropriate amount of power from the reader’s probe and trigger full power mode. This would be a confirmation that the problem has to do with the reader not waking up for transponders with smaller sized antennas like rings.


I’m not at the hotel anymore but I did grab a picture at one of them.

I did recently get a RDC, but I didn’t think to try and tap it while tapping the ring, nor did I think to get picture/video while holding the RDC to the reader.

Interesting. These are in the wall not the door? Does the door have an electronic strike?

Someone reported earlier that many of these wired readers are operating on the lowest possible voltage and performance is pretty terrible because of that. I wonder if these are similar.

Its in the door, the reader is about where you’d expect a residential deadbolt above the lever-handle. Also about the diameter of a residential deadbolt (slightly bigger than the card width, but smaller than the card length). Though a few were on a wall (e.g. parking garage gate, elevator) with the same style circular reader.

Inside its just a long metal box (don’t have pics of that) between the reader at the top and the lever below. It also had some kind of “automatic deadbolt” thing instead of throwing a bolt for privacy you moved a small lever that didn’t operate a latch but felt more like a light switch in force required as it rotated.

Also - I just found a pic of the other style I haven’t successfully got to read a ring OR small keyfob. This was also at a Hilton property (DoubleTree), although they had the same round one pictured earlier on other doors (lobby rear access, parking, elevator, etc). Same design on the inside and same size reader but seemed more oval than circular.

My guess based on the 2 Hampton Inn and 1 DoubleTree locations is probably most Hilton chains have this style of lock on the rooms.

EDIT: And another picture (blurry but provides perspective) of the round reader (these do work with the round blue china keyfobs):

ah ok… so this is very likely a battery powered lock and the RDC + ring might prove out the theory that the problem is the low power tag detection power saving approach. there are two ways to test this;

  1. place RDC over reader, then bring the ring up to and around the RDC while it is still held to the lock. keep trying different positions.

  2. place the RDC over the reader until you see the LEDs blinking, then quickly remove it and place the ring to the reader. swap it quick like this;



Not totally sure when I’ll have a chance to get in another hotel, but I shall keep this in mind to try.

Would be a bit of a bummer tho, being able to fist-bump the reader and unlock a door would be SUCH a cool factor.

1 Like

Tried to trigger a Hampton Inn (Hilton) by stimulating the lock with an RDC and an xMagic but did not have any luck…

Not exactly relevant, but an extra data point for the curious.