NExT invalid tag error whenever I scan it

I just got an implant the other day, and it won’t scan right. It worked like a charm the first few times, but now all I get is error: invalid tag on my phone. NXP taginfo can see my chip and read it, but no other app, not even tagwriter or the DT app can access or change the info.

Hey buddy.


Your scenario sounds just like a typical swelling problem we see here VERY frequently after a fresh install

  • Implant :syringe:
  • Reads fine
  • Swelling starts
  • Reading performance declines
  • Swelling reduces
  • Reading improves

Just give it a week or so and you should be back to reading and writing with no issues at all.

So this is a normal thing?

Which DT app?

Also TagInfo doesn’t write to the chip, It reads the Chip, but in a different way that tag Writer.

Can you show us what result you get with TagInfo

Did you write any NDEF Records to your implant with TagWriter?

Which Implant do you have?

I have the NExT rfid plus nfc chip. Neither DT app will work. I used nfc tools plus to write onto the chip, and I could scan it and have access to the phone number I put on it. But when I tried to change the information, I got the error

Which apps?

Can you still READ with NFC Tools?

Dangerous things support, and Dangerous nfc. Nfc tools pro will not read anymore. This is what taginfo gives on a full scan

This is for sharing your files to DT for support, you can also use it to “wipe” the xNT / NExT

Click “Blank NDEF” then present your NExT

When you have done this, Try and write an NDEF record with TagWriter

You don’t really need this for the NExT, It was for the xNT that weren’t password protected from the factory , Your NExT is already protected.
You can delete this App

ALSO what @yeka says :arrow_heading_down:

1 Like

TagInfo saying Ultralight is weird. The errors are also kinda weird.
I wouldn’t write to it anymore until swelling is surely down, just to be safe.
From my noobs perspective, you should still be able to read a youtube url from there.
Once you get consistent reads you can try further with whatever other people here say.

1 Like

PM3 detects the NTAG216 as potentially a ultralight card (and also potentially a NTAG21x), so maybe it is just not reading properly because of the swelling.

1 Like

Totally agree with this!


I’ve had the rfid plus nfc chip in for about a week now, and I still can’t read or write onto the chip. In another thread, they said it was swelling. My galaxy s20+ has no issue sensing the chip is there, it just can’t access the information, unless it’s in nxp taginfo.

So after a quick look, everything looks fine.

If you or somebody else scans it, it doesn’t link to your YouTube video, correct?

How did you write that to it in the first place?
Was that Tag Writer?

So have you tried writing another NDEF data set with TagWriter?
Or using TagWriter to format it?

I used nfc tools pro to write it onto the chip. Someone in another post mentioned using taginfo. When I wrote onto the tag first, it scanned no issue a few times, then nothing but invalid tag errors. I was going to try using tagwriter to reformat my chip, but I can’t due to the the error

And this is not working either?

No unfortunately

Hmmm, I’m pretty confused that you can read it with Taginfo but NOTHING else.
It really makes no sense to me…
I am not sure what else to suggest sorry.


So what, I should just cut the fucking thing out?

Well, that is obviously an option. Perhaps you should see if some other random person on the internet has any suggestions first.

Most of the people on here are random end users who are not employees of Dangerous Things.

No, I don’t have a clue about your chip, but I am not an expert on tag formats. I don’t know, for example, if a password is set on that tag.

I’ve been browsing every Google search suggestion and forum post for a week now, and I have to have a working solution come to light