NExT troubleshooting

Hello everyone, been sleeping on attempting to fix this issue for a while now.
About… 8-10 months ago, I had an NExT implanted and I’ve been having an issue since day one (of it being healed enough).
The Low Frequency part works like a charm, which is awesome, however the High Frequency part only allows me to write a very small amount of data, much smaller than it should be letting me.
I did NOT set a pin using the Dangerous NFC app after I had it installed, I simply tried to write a contact card to it like I have done a lot of times on my XM1.
Any help to figure out why it’s like this and hopefully a solution to the problem would be much appreciated, full implant dump attached.

04-28-63-32-0A-54-80_2020-12-30 17-13-13_taginfo_scan.txt (8.4 KB)

All your config bytes seem to be in order. What are you using to write to the tag?

1 Like

So how did you write to it, what app and what data. Looking at the info dump its written a small segment of text what was the full text?

@Satur9 snap

1 Like

What’s currently written to it could be disregarded probably as that was just to see if I COULD write something smaller.

Right so let’s use NFC Tools.

Head to this page and select “erase tag”

Head over to the write page add a text record

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

Then read it and let’s see what we get.

Hopefully something like this

1 Like

I used NFC Tools Pro, same as with my xm1.
Data was just a contact info thing, my name, nr, that kinda thing.
I also tried (after first failure) with sharing it from my contact list to… trigger writer I think. That was a while ago and on another phone so I’m fuzzy on the details.

Huh yeah that works, 676/820 bytes. Why is it saying the tag is too small for a contact card then?
Granted that was in a different app, NFC Tools Pro doesn’t let me just write a vcard from my contact list, which is why I was trying some other way…
Though I suppose I can just save it in NFC Tools Pro instead.
Reason I want to use a vcard from my contacts is that I wanna be able to re-write based on the social situation.

Where you trying to use NXP tag writer? That app is seriously broken at the moment

As I wrote above, the details are a bit fuzzy atm, like I said I’ve been sitting on this “issue” for a while.
I THINK it was trigger writer, which… I have no idea why I was using that now in retrospect.
I DID just try with NXP Tag writer and it seemed to write a contact just fine?
Have I really been sitting here thinking it was fucky somehow and it was just the app the entire time? I feel like I tested more than one way at the time. Hard to say, was a while since I actually got off my ass with it.

The main thing is that it works :slight_smile:

1 Like

I think after Amal had me try the dangerous NFC app to set a pin and it didn’t wanna let me that just reinforced the idea in my head something was wrong with the chip.

Well to quote Moss from the IT Crowd, “Egg and MY face, were in alignment”.
Cheers mate, thanks for the help, I’ll be in my hole being disappointed at myself haha


If you have Linux and a ACR122U or other PM53x-based reader, try this script here:

The script will let you easily craft a vCard that’ll fill the implant to the brim. Just loose the photo bit if you don’t need it.

Do you have a photo attached to your VCard?
If so, that will easily blow out your 888 bytes until you small-ify it.

Rosco has a great solution that he liked to above to fix that issue.

I would have suggested this. I didn’t realise there were issues. I still use it

but you can use that to also compress/shrik your image.

Nah no pictures or anything, just text.