PM3 Easy install issues Mac - Sonoma

So there is an issue right now with the current iceman build that doesnt allow me to compile on sonoma. Something about Python@3.12 missing python dev.

I tried reverting to 3.11 and symlinking… nothing worked.

Here is what did work

I had to go through the Mac Ports install.

so… These are the exact steps i did to get my PM3 back up and running

Try this…

  1. download and install Macports

  2. Run this command to install the dependancies for the Proxmark
    sudo port install proxmark3-iceman +pm3generic

  3. go to where you cloned your Proxmark Repository and go into the /proxmark3 folder

  4. run the command to compile the source
    arch -arm64 make clean && make -j8 all

  5. press and hold the button, plug in your PM3. release the button. if 2 of the 4 lights are on on your pm3 it is in bootloader mode. If just one light is on (power) you are not. Youll have to unplug, hold the button, plug it in and keep the button pressed for the next 2 commands.

    a. ``./pm3-flash-bootrom``
    b. ``./pm3-flash-fullimage``

when both are complete you can run it with:


if you type just pm3 it means you are attempting to run the brew installation and it is not going to work.

Let me know if this worked for you.


Shouldn’t the Proxmark3 Easy be easy? haha

Ok so that worked with a couple changes.

I go into cd proxmark3

When getting to number 5 I have to run
and pm3-flash-fullimage without the ’ './

then pm3 - to get the client running.

I disconnected everything to try again l and have to do the above 3 things each time in order for it to be recognized.

If this continues to work then it is what it is.

I’d love it to be at the point where I can just plug it in and do
cd Proxmark 3



I would like that too, the downside, and reality to using a mac, is that we often have a bunch of different issues that others dont have to deal with as a result there are updates for windows machines pushed much more frequent than our own.

Once the brew fork is fixed you should be able to just Brew install Proxmark3 and run the pm3 command and it just works.

A lot of this is apple’s fault for switching to ARM. everything was working great when they were on intel chips. the move to arm messed up a lot of my programs and outdated items just will not run on arm. :frowning:

1 Like

Well, as long as it works I’m happy.

Thank you so much.

I’ll transfer to Kali eventually