PM3 Easy install issues Mac - Sonoma

Hey all,

Just got my PM3 and I’m running into issues. I’ve followed a few different walkthroughs between wiki and GitHub - finally got things to the Ice man welcome page but then I get an unable to connect to Proxmark3 error when trying “pm3

I’ve tried unplugging, and holding the button when replugging but the same thing happens.

Any help is really appreciated.

[+] Writing segments for file: /opt/local/bin/…/share/proxmark3/firmware/fullimage.elf
[+] 0x00102000…0x0015860d [0x5660e / 692 blocks]

@@@ @@@@@@@ @@@@@@@@ @@@@@@@@@@ @@@@@@ @@@ @@@
@@! !@@ @@! @@! @@! @@! @@! @@@ @@!@!@@@
!!@ !@! @!!!:! @!! !!@ @!@ @!@!@!@! @!@@!!@!
!!: :!! !!: !!: !!: !!: !!! !!: !!!
: :: :: : : :: ::: : : : : : :: :
. … … . . … … . . . . . … .

… ok

[+] All done

[=] Have a nice day!

johnmcevoy@Johns-MacBook-Pro-2 proxmark3 % pm3
[=] Waiting for Proxmark3 to appear…
[=] Session log /Users/johnmcevoy/.proxmark3/logs/log_20240311162535.txt
[+] Using UART port /dev/tty.usbmodemiceman1
[!!] :rotating_light: ERROR: cannot communicate with the Proxmark3

johnmcevoy@Johns-MacBook-Pro-2 proxmark3 % pm3
[=] Waiting for Proxmark3 to appear…
[=] Session log /Users/johnmcevoy/.proxmark3/logs/log_20240311162626.txt
[+] Using UART port /dev/tty.usbmodemiceman1
[!!] :rotating_light: ERROR: cannot communicate with the Proxmark3

Let’s try this for starters

This worked - thank you so much!!!

Is this the process anytime I want to run the client? Like I have to flash all every session?


This would not be normal.

You could probably answer your own question, try again and let us know how it goes.

depending on your setup, you should just have to change directory to your proxmark3

so if you aren’t in the proxmark3 directory

cd Proxmark3


1 Like

very strange.

So yesterday I followed the steps above and it worked - got in and was playing with reading card data etc.

went through he process again this am and I got to the ice man welcome but when trying to run the client it just times out or says it cannot connect to the Proxmark.

from the terminal home if I do cd Proxmark to get into the directory then pm3 I get the below and it just stays on that page:
johnmcevoy@Johns-MacBook-Pro-2 ~ % cd proxmark3

johnmcevoy@Johns-MacBook-Pro-2 proxmark3 % pm3

[=] Session log /Users/johnmcevoy/.proxmark3/logs/log_20240312193824.txt

[+] loaded /Users/johnmcevoy/.proxmark3/preferences.json

[+] Using UART port /dev/tty.usbmodemiceman1

looks like it isnt detecting the proxmark3

can you run

ls /dev/tty.*

It will list the current serial connections you have. if it is listed as anything other than usbmodemiceman1 you can call that modem when running pm3 with the command

pm3 -p /dev/tty.whatveryourpm3modemnameis

Then when the screen loads its likely we will understand why. Im willign to bet your bootrom isnt flashed right

1 Like

Thanks for staying on this with me.

johnmcevoy@Johns-MacBook-Pro-2 ~ % ls /dev/tty.*

/dev/tty.Bluetooth-Incoming-Port /dev/tty.usbmodemiceman1

johnmcevoy@Johns-MacBook-Pro-2 ~ % pm3 -p /dev/tty.usbmodemiceman1

[=] Session log /Users/johnmcevoy/.proxmark3/logs/log_20240312202753.txt

[+] loaded /Users/johnmcevoy/.proxmark3/preferences.json

[+] Using UART port /dev/tty.usbmodemiceman1

[!!] :rotating_light: ERROR: cannot communicate with the Proxmark3

So try going back and reflashing the Bootrom?

It doesnt seem to be able to communicate with the Proxmark.

So, first, restart. Try again.

Next try the button trick. You shouldnt have to use the button trick everytime but i had a lot of issues last year before i was able to flash it correctly.

Restarted the computer and went back over everything multiple times now.

I keep getting the same ‘ERROR: cannot communicate with the Proxmark3’ when trying to run pm3.

with all the other steps you mentioned above in order for it to pop up as ‘found’ I have to plug it in while holding down the button right after hitting enter for the command.

Usually the button truck is only needed for flashing.

And you should do it before you hit enter. It just enters the pm3 into dfu mode essentially

Going through the entire process is unnecessary. After you get the code downloaded and complied and your proxmark3 updated with the complied firmware, the only thing you need to do then is plug in the proxmark3 and run the client… the last two steps;

  • plug in to USB (no button)
  • run pm3 to start client

It’s possible running through the entire process a second time has trashed your compiled code. You may need to go back to the beginning beginning. First, invent the universe… then go from there.

I’m at a total loss now.

Read everything I can find, and been through all the above countless times.

Getting stuck at the same point over and over.

ERROR: cannot communicate with the Proxmark3

if I just type in proxmark3 in command I get the below saying it’s in offline mode - something simple somewhere needs to be tweaked but I don’t know what

Last login: Thu Mar 14 17:14:22 on ttys000
johnmcevoy@Johns-MacBook-Pro-2 ~ % proxmark3
[=] Session log /Users/johnmcevoy/.proxmark3/logs/log_20240314231614.txt
[+] loaded /Users/johnmcevoy/.proxmark3/preferences.json
[=] OFFLINE mode. Check “proxmark3 -h” if it’s not what you want.

8888888b. 888b d888 .d8888b.
888 Y88b 8888b d8888 d88P Y88b
888 888 88888b.d88888 .d88P
888 d88P 888Y88888P888 8888"
8888888P" 888 Y888P 888 "Y8b.
888 888 Y8P 888 888 888
888 888 " 888 Y88b d88P
888 888 888 “Y8888P” [ :coffee: ]

Release v4.18218 - DEFCON is Cancelled
[ Proxmark3 RFID instrument ]

[offline] pm3

What do you get with proxmark3 -h

it just lists all the commands, offline mode

[offline] pm3 → proxmark -h

help Use <command> help for details of a command
prefs { Edit client/device preferences… }
-------- ----------------------- Technology -----------------------
analyse { Analyse utils… }
data { Plot window / data buffer manipulation… }
emv { EMV ISO-14443 / ISO-7816… }
hf { High frequency commands… }
hw { Hardware commands… }
lf { Low frequency commands… }
nfc { NFC commands… }
piv { PIV commands… }
reveng { CRC calculations from RevEng software… }
smart { Smart card ISO-7816 commands… }
script { Scripting commands… }
trace { Trace manipulation… }
wiegand { Wiegand format manipulation… }
-------- ----------------------- General -----------------------
clear Clear screen
hints Turn hints on / off
msleep Add a pause in milliseconds
rem Add a text line in log file
exit Exit program

[offline] pm3

What lights are on on the pm3

3 lights - power light and 2 of the ones that are on/off/on/off

I apologize for blowing everyone up, but I guess thats what the support forum is for right?

So, when going back through things I’m getting some errors when I do clean make clean

make: *** [armsrc/all] Error 2

1 warning generated.

mv -f obj/lfdemod.Td obj/lfdemod.d

mv -f obj/emv/emv_pk.Td obj/emv/emv_pk.d

1 warning generated.

mv -f obj/cliparser/argtable3.Td obj/cliparser/argtable3.d

mv -f obj/cmdhfmf.Td obj/cmdhfmf.d

1 warning generated.

mv -f obj/cmdhfmfhard.Td obj/cmdhfmfhard.d

make: *** [client/all] Error 2

johnmcevoy@Johns-MacBook-Pro-2 proxmark3 %

Photos are way better here than words. Can you post a photo? Sounds to me like the bootloader mode is borked.

1 Like

There is currently a bug with the Mac Install compiling. Im working through the github to see if there is a fix. it isnt you @Johnny_craic as i have also borked up my install too :slight_smile: