PM3 Easy not showing up in Device Manager

Hello! I just got a new PM3 Easy from DangerousThings (so I’m assuming it has Iceman firmware correctly installed). Trying to follow the Getting Started instructions (Getting started with the proxmark3 easy) and I’m already stuck at step 1, as the device is not showing up in Device Manager. Also tried on macOS and the device is not detected when running pm3-flash-all and doesn’t appear under tty.usbmodem*. I also tried with multiple cables without any luck.

Any tips for a noob?

1 Like

you shouldnt need to do the flashing, its been flashed for you. you just need to run the pm3.exe

make sure you’re plugging the cable into the USB port on the short end of the device

but in this situation do the button trick

  • unplug the device
  • hold down the button
  • plug the device in while still holding down the button
  • keep it held! run the pm3-flash bootrom command, and then the fullimage (don’t do flashall)
  • only let go of the button when both are done

make sure you’re plugging the cable into the USB port on the short end of the device

Wow, that was it, my username checks out. I managed to successfully run both pm3-flash commands from my Mac but it still won’t connect when I just run pm3 by itself (whether I plug it in while holding the button or not). Note that pm3 --list returns the correct port only when I plug it in while holding the button.

Any idea of what I’m doing wrong?

1 Like

Tried from my Windows laptop, pm3 works!! Thanks for the help :grin:

yeah i was thinking it may be a problem with the new M1 chip if you’ve got the new macs

1 Like

I don’t have the new M1 chip but I’m wondering if this may be due to me not compiling for the correct hardware on Mac. I didn’t have an equivalent of switching from PLATFORM=PM3RDV4 to PLATFORM=PM3GENERIC when I was following instructions for the Mac.

AH ok yeah thatyll do it

Assuming that you are using homebrew on mac then you can follow the information above.

I’m a MacOS user too and new to everything here… experienced with software tools and installation. I wasn’t able to get it running. Tried on OSX and after that under Windows 10 too.

My question. I only have three lights on when I plug it in. Two times the LEDs where bright, but since I’m trying to connect not.

Didn’t see the USB/COM device unter windows and in the /dev/tty.* nothing like it should for the pm3

Anyone out how can give me an advice about the three lights. The don’t blink just a little on. On my Mac I’m using an USB-C hub.


Update … Nothing changed on the software and hardware. Plugged in the USB with twice with 2 seconds between and now, the white led is on. I see the /dev/tty.usbmodemiceman1 - now I get the message: Capabilities structure version sent by Proxmark3 is not the same as the one used by the client!

Let’s see how to get the correct software on my mac …

It works. Looks like I have a funny board. Need to plugin two times and it works. Also to get if flashed.

If somebody has the same - three lights not shiny - try plugin twice to get the bright white led on the left side on.

sounds like a cable issue more than anything tbh

try swapping the cable for one you trust, the one that comes with the device is not spectacular and may be the cause of your problems


Thanks, tried three cables, two hubs, osx and windows. All with the same result.