PM3 "Un-flashing" when disconnected (resolved)

Hi, I’m looking for help with my PM3, it came in the mail mid Tuesday afternoon, set up was easy, and works great. However, every time I unplug it from my laptop (currently learning to use it on my breaks at work) it seems to be unflashing. Every time I plug it back in and boot up the cmd workspace, it says the pm3 is offline and to check the proxmark3.exe file. When I run the file it says that bunch of files are missing and to try reinstalling the program. Reflashing the pm3 gets it working again but I have to do that everytime. Is there something I’m doing wrong?

Could you post some pictures of the errors it’s giving you?

1 Like

Of course, and sorry for the delayed response


After a fresh boot of proxspace, it shows that the pm3 is offline. On the left it does show that it is connected (the set up tutorial says it should be com6, but mine shows as com5), Near the top of proxspace it says its in “offline mode and to check “proxmark3.exe” if its not what you want.”
Screenshot 2024-06-05 014033
Screenshot 2024-06-05 014041
Screenshot 2024-06-05 014049
Screenshot 2024-06-05 014102
After searching the proxmark3 file that was downloaded and where im pretty sure everything is kept, these are the errors that pop up when I run the executable. When I ok through them all, it just closes the window.

1 Like

Which guide were you following?

Could you try the relevant pre-compiled binaries from this site?
https://proxmarkbuilds.org/

Easy Download links:
If you have a PM3 Easy

If you have an RDV4

1 Like

I’m following the Getting Started Guide that is listed in the Proxmark3 listing from the DT Proxmark3 product page

I can try those and I’ll see if the problem persists

1 Like

So to start, the video tutorial did say that one of the ports on the PM3 is the “correct” port and used the bottom port for the tutorial. Im pretty sure I used the side port for my original flashing and re-flashing when I was at work as I wasnt (and still am not sure) there was a difference and what each was for.
However, after unplugging the PM3 and letting it sit for a couple minutes, the problem seems to only persist and show as “offline” when plugging it into my laptop. Plugging it into my PC does show the PM3 as connected.
From here, Im assuming it might be something to do with proxspace on my laptop and am going to try a full reinstall of proxspace on my laptop

One of the ports, I believe the one on the short side, is for data and power, it’s the one you use with your computer

The other port is just for power, it’s for using the PM3 in standalone mode

Did you try those binaries?

1 Like

I did use the recommended listed for the PM3 easy, I couldnt get the official one to see the PM3 in the com5 port in order to continue with the “flash bootrom”. I did do this on my instead of my laptop

After doing a full wipe, re install, and set up of the Proxspace file from the store page, it still showed as offline.
So I copied and moved the new Proxspace file provided from the process you had me go though over to my laptop, and it shows as connected consistently, even after letting the Proxmark3 sit unplugged for a few minutes. It does now require the PM3 to be connected even load and allow me to go through the commands however, but that should be fine since the program isnt usable without the PM3 anyway (at least to me with the limited knowledge I have at this time)

Thank you so much for your help!

1 Like

Why are you launching the client this way? Use the ./pm3 script instead as the script will find the port for you… I think this is your issue. You are starting the client without specifying a port so it goes to offline mode by default.

3 Likes

At the end of the walk through I was using to originally set up the PM3 (this one thats listed in the product description), it lists near the end to do it that way.


However, in the file that came with the new binary on the PM3 when launched, I dont have to do any of that, it just waits to see the PM3 to be plugged in and does everything it self.

2 Likes