PM3EZ device / fw mismatch after flashing on linux [SOLVED]

Hello Everyone :slight_smile:

Im still pretty new to the proxmark3 but I ran into an issue. After succesfully flashing and running the PM3 on windows without any issues i later installed it on my linux machine. After doing this everything worked fine untill i ran the ./pm3 command and got the “Target… device / fw mismatch” warning. I cannot for the life of me figure out what the issue is. I double checked my Makefile.platform file. I have run the Make clean && make all command countless times and reflashed many more times. Even when i try to correct the damage on my windows machine i cant get the mismatch error to go away. There are no other errors either while flashing so i dont know why this is happening.

thanks in advance for any help :))

You can check this out.

In order for your proxmark to work, client, bootloader and os/firmware of the proxmark must be the same.
What proxmark do you have and what is in your makefile.platform
Also sharing the exact mismatch message would help a lot :slight_smile:


Hi r00t!

I flashed the bootrom and fullimage in dfu mode but the issue persists. here is a screenshot of what the pm3 software shows at startup

I dont know if the qt warning has something to do with this or not. As per your second and third questions, I have the proxmark3 easy that was sold by dangerusthings and here is the screenshot of the Makefile.platform

if you see in the screenshot, the client version is diff from the bootrom and os. This is the cause of the issue. In order to address it you need to flash your proxmark as I mentioned.
It seems you’ve cloned the latest master branch on the linux box, and build from it. That’s fine.
On the windows box it seems you’re running the previous stable release.
Unfortunately this wont work as is, in case you want to have both windows and linux using the device.
My next suggestion, reinstall proxmark on windows - current stable is 17140, then flash the divice bootrom and firmware, go to your linux box and clone from 17140 tag, then make it.
This will make both os clients the same and they will be able to comm with the device just fine.


ah this makes a lot of sense as to where the issue came from. i hadnt even noticed that the client and is different. Now my next question is how can i choose what release to install?

Nvm my previous question. I am however still having troubles flashing the pm3. Whenever i flash it i get "ok"s however when i then start the pm3 software it says it is still using the old 16717 version. I have tried the button trick but the issue remains.

I had a similar issue last night on Ubuntu trying to update. I had to do a clean install, then use pm3-flash-bootrom first, then pm3-flash-fullimage and it fixed my firmware mismatch.

1 Like

I think I know what is going on here.
Check the output of the flash command.
It takes the files from /usr/bin/…/share/proxmark3/firmware bla bla
By any chance you did make install ? or installed the pm from a package or something.
go in your proxmark3 dir, from which you’re executing the ./pm3
put the device in dfu, then ./pm3-install-bootroom after this is done ./pm3-flash-fullimage

This is default linux behaviour. if you exec in a shell ./pm3-flash-fullimage it means run it from the current dir, if you do pm3-flash-fullimage it will look into your executable paths.

to clone the stable branch use this
git clone -b v4.17140


as per usual the fix was blatenly obvious. I was missing sudo when running the pm3-flash commands. So after running sudo pm3-flash-bootrom abd sudo pm3-flash-fullimage all the previous issues went away. The love/hate relationship with linux continues :slight_smile:

Thank you guys for helping me while i was headbanging my table :))


wtf, i never needed a root perms to flash the proxmark.
case seems to be closed @Pilgrimsmaster


Rather than closing the topic, I’ve simply added a [SOLVED] in the title.

( Not sure if that’s what you even meant by your comment, but, heres why anyway)
Closing means nobody can post to the thread, so if somebody had further questions after following the thread, they would need to start a new one and would likely reference back to this one.
I think its easier/ better to leave the topics open


I’m really glad you got things sorted, I’m very curious why sudo worked and non-sudo didn’t.
Do you have modemmanager installed?
Did you run sudo make accessrights?

This is so confusing. sudo might be a modem manager issue, or you may have multiple versions of the file(s) bootrom.elf and/or fullimage.elf and sudo (root) doesn’t have the same pathing as your normal user.

Can you try this for me? (If you don’t mind.)
While inside the directory with the proxmark3 code/git checkout.
ls -l /usr/share/proxmark3/firmware/bootrom.elf /usr/share/proxmark3/firmware/fulliamge.elf
ls -l bootrom/obj/bootrom.elf firmware/fullimage.elf
sha1sum /usr/share/proxmark3/firmware/bootrom.elf /usr/share/proxmark3/firmware/fulliamge.elf bootrom/obj/bootrom.elf firmware/fullimage.elf | sort -n

I suspect make install or sudo make install didn’t do the expected things.


It’s a colloquialism… “case closed” means it was solved, so to speak.

Yeah, I got that, I just wasn’t sure if he meant I could close off the thread because of that

1 Like



Hi sorry for the late reply,

i dont have multiple files of the bootrom.elf or fullimage.elf as far as i can tell. As to the user permissions i have for the bootrom.elf/ fullimage.elf under the firmware folder -rw-r–r–. then for the bootrom.elf under then obj folder i have -rwxr-xr-x.

as to the SHA hash i have the following:
b88f1291e09eee02eb82782c83c2e07de3e728bf fullimage.elf
902da8b0cb403749c00a4844dce080821b357166 proxmark3/bootrom/obj/bootrom.elf
4068b4c88270e78c50bfe4f39fafa04b9c8cc354 bootrom.elf

I hope this helps :))