Potential defective magic ring?

I suspect I’m having a defective magic ring that I just bought, but I’m not sure how to tell if this is the expected behavior or not… essentially it’s just nearly impossible to read the LF side of the ring with commercial readers.

Background: I don’t think it’s an issue with my programming process or the reader itself.

  • I only have two readers for validating: a proxmark3 and the one I’m trying to clone for (which I do not have control over).
  • before I ordered the ring, I cloned the key with a random t55x FOB on the first try and it works flawlessly
  • a rando t55x ‘card’ that I had lying around also works repeatably

I had significant difficulty getting the t55 side of ring to operate initially:

  • it would read the pre-programmed em tag just fine (only tried once, a lf search that revealed the tag)
  • t55xx detect/read/etc was useless it always came up not found
  • t55xx commands would work sometimes, but i had to hold the ring about 3cm of the antenna which is way farther than any tag Ive used before
  • Eventually I could get the ring in just the right spot to get writes enough writes/reads in to verify that the chip contained the correct data (see below, redacted areas are the correct HID string) and the lf hid read command returned the correct ID
    • note that sometimes when the read failed, it would show some of the correct blocks but in the wrong place, and some random data (like block2 was random and what should have been in block 2 showed up in block 5 or similar).
  • Even with a ‘good’ program, the ring will not even activate the unmarked reader on the door no matter how much I present, swipe, stroke, dance, etc
  • If I present to a good quality HID door reader it will only activate the reader in one very specific position near the edge and only after a few tries. I don’t know if it reads correctly or not since it’s just a rando reader in the building, but it’s the only thing that will even pretend there’s something in the field…

So. Is this a bad ring or am I just unlucky with the geometry of the reader coils somehow? Is there anything else to try like adjusting some of the t55xx control bits that are a mystery to me?

Thanks for your help!

“Proof” of good programming:

[usb] pm3 --> lf t55xx dump
[+] Reading Page 0:
[+] blk | hex data | binary                           | ascii
[+] ----+----------+----------------------------------+-------
[+]  00 | 00107060 | 00000000000100000111000001100000 | ..p`
[+]  01 | <redacted>
[+]  02 | <redacted>
[+]  03 | <redacted>
[+]  04 | 00000000 | 00000000000000000000000000000000 | ....
[+]  05 | 00000000 | 00000000000000000000000000000000 | ....
[+]  06 | 00000000 | 00000000000000000000000000000000 | ....
[+]  07 | 00000000 | 00000000000000000000000000000000 | ....

I don’t have a magic ring, so i can’t speak from actual experience, but what you are describing, TO ME, it sounds like a coupling issue.

Did you watch the video (i imagine you did, but just want to confirm) From 4:05

Then can you try a couple of things for me?:

  • Can you take a photo of the ring placement on the PM3 LF antenna

  • Try placing your magic ring and every imaginable orientation on / around the antenna and try reading / writing

  • putting a non conductive material between the antenna and ring, preferably something adjustable (sheets of paper, start with ~5 sheets and work you way up in increments of ~5) and try reading / writing

1 Like

Send pix of your ring on the proxmark3. Bad coupling is more likely

1 Like

Hey guys thanks for suggestions!

I’ll attach a pic of the only spot where I can hold the ring and have it reliably read/write, but to your questions:

  • I’ve tried all possible orientations around the PM3 using lf tune and I get, at best, about a 0.8-1v drop for the tag. The pic is the best at about 1.1v. Other t55xx tags drop 3-4 volts in multiple orientations, so I don’t think it’s a problem the PM LF antenna.
  • stacking paper did not work at all. The ring could not be found/read even when I stacked enough paper to get it up to the height where it reads when I hold it
  • I don’t think it’s a programming issue, since when I hold it in that one spot I can reliably dump, reprogram, lf hid read, etc. I even tried writing a few fc/cn pairs and lf hid read came back correct.
  • The ring works on the proxmark, but only in this one spot, and only after a few tries (ie need to write/read a few times to get it to ‘take’)

Given that the device is, apparently, capable of being written and read correctly - is this an antenna issue with the ring? It still fails to activate any commercial LF except the one door at work I don’t own, and even then just that one, the same reader on that guys other door does nothing (and yes, he came and asked me wtf I was doing loitering outside his door messing with his reader so that was fun :stuck_out_tongue: )

1 Like

Sounds frustrating , but I think it may be a Proxmark issue, rather than the ring itself.
The reason I say that, as most people with the MagicRing seem to have little to no issue with it, and their PM3s are different to yours.

Where did you getvthat one from
It looks to be an older design, and im guessing the performance is slightly different with it.

Do you happen to have, or access to a Flipper or iCopy? Or possibly another Proxmark3?

1 Like

It’s from rsyc corp, a few years old to be sure but it’s never had a problem with other LF tags. It says “proxmark3 rdv2.0” on the silk screen. It’s also running the latest iceman firmware and client, so it’s pretty much new. Does your circle mean you think there’s something wrong with how the antennas are hooked up?

I would be hesitant to blame the pm3 alone for a few reasons:

  • If it was just the pm3, the ring should be able to trigger other commercial readers once it’s programmed correctly right? Both wall readers and the omnikey we use to enroll the door readers fail to even recognize there’s a tag there (until I rotate it too close to the HF side…).
  • the lf tune command provides pretty visceral feedback on the coupling. I think the fact the the magic ring only drops it by ~1v while other tags (including other t5xx rings) drop it 3 more during the same session would indicate the antenna is tuned and functioning correctly, and that it’s the ring that’s failing.

Is there some sort of test that can show the device is working correctly?

no, just pointing out how I knew it was a little older than what most others are using.
Nothing wrong with it and it sounds like it is working fine, It just doenst seem to couple as well as the others do with the rings, so thats why I “blamed” the PM3 over the ring.

I dont have a magic Ring so I cant compare anything for you directly unfortunately so I just have to go off anecdotal comments.

The fact that you can read and write to the ring although not easily, tells me it is not faulty, although maybe the tuning is off :man_shrugging:
Batch manufactured, I would have expected more consistency…same goes for PM3s though I guess…and card readers

Ret issuing an LF TUNE command, take note of the average voltage level, then approach with the ring. Hold it where you get reads and note the voltage level… then drop it to the antenna and set it down… note the voltage level.

Basically coupling is kinda black magic. The field is a donut shape, and how that shape interacts with a transponder depends a lot on the geometry and power output and inductance tuning and capacitance of the reader, and the interplay with the inductance and capacitance and geometry of the transponder. This creates a kind of green zone on the z-axis which a transponder works well with a reader. It’s totally possible for the mismatch to create a lower performance when the transponder is closer to the reader.

Since it does work at a distance, my thought is that the problem is the specific parameters of the ring and the proxmark3 rdv2 you’ve got. A new ring might work better, or it might basically be the same. Hard to tell what the issue it.

But I can tell you that we programmed the LF side ourselves on each magic ring by placing it straight down on our proxmark3 easy LF antenna and running the programming and check… so your ring would not have been performing any differently to any other ring we programmed… hence my thought that it might just be an issue unique to the interplay between the ring and your proxmark3.

yep. when I quoted you the 1.1v difference that was the peak drop anywhere within the detectable range of the reader. It was also where it was able to read.

I would agree in a vacuum, but in this case we also have the fact that several other commercial readers are completely unable to register the tag. I think the simpler explanation is that the PM3 is better, not worse, than the commercial readers. Indeed, this has been my experience in the past. Barely being able to be read by the pm3 while being ignored by ‘regular’ readers would make sense if the antenna field in the ring itself were degraded.

Gotcha. Yeah something is up. Will continue via the ticket.