Proxmark 3 easy setup help

So I just installed 1/2 NExT chips. post coming about that soon. I’m just setting up my proxmark and followed this guide Getting started with the proxmark3 easy
I got to setting up the makefile.platform but when notepad opened there wasn’t any text. Where should I go from here? OS is windows 10

Make sure it’s Makefile.platform, with a capital M. Did you copy Makefile.platform.sample like the guide says? That should have pre-populated Makefile.platform.

cp Makefile.platform.sample Makefile.platform

Yep, I did, unless I made a dumb mistake I’m not picking up.

I also saved it under C:\ProxSpace so there shouldn’t be issues with installation

You missed an F in platform there in your last command :slight_smile:

You wrote Makefile.platorm, not Makefile.platform.

I’m an idiot. Apologies to everyone. These are the mistakes that plague my life. Thank you though

1 Like


Feel free to post more in this thread or DM me if you have any more issues during setup :blush:


awesome thanks man. I’ll keep that in mind. So far so good though. About to flash proxmark

Edit: Ok @darthdomo I think I do actually need help again. I can’t seem to get the ‘lf hid fskdemod’ to work, it just seems to be spitting out the list of commands (like linux does when you enter a command it doesn’t like. I did however get it to work using the ‘If hid reader’ command. I’m not quite sure whats going wrong (I’m using the guide here and I am just trying to clone my HID prox card

that being said I was trying to run it in client, which may have had something to do with it

1 Like

All of the commands have help so try lf hid --help
If that lists fskdemod then try lf hid fskdemod --help

1 Like

So, I would keep in mind, the command structure has changed dramatically since that article was written. If you’re just trying to clone your card, you should be able to do lf hid clone -r ID_HERE, with ID being whatever hex value was shown in lf hid reader.


Just remember, that blog guide is dated

Kevin Chung

May 29, 2017 •

There has been some syntax changes since then.

I would recommend you going through in steps

lf hid
lf hid ...

it should prompt you with your available next input options…


Yeah, What @darthdomo said



Ahhh ok. That makes sense yeah. Perfect, thank you for the help. I’ll continue to go ahead in that case. It’s funny. The installation was the easiest part of it

Edit: putting this here since I didn’t want to make a whole extra post for it. I wasn’t typing “Lf” I was constantly typing “if” so no wonder none of the commands worked. At least I solved it eventually

1 Like