Proxmark3 Easy - Curriously Doging Flashing

Hi everyone. Just want to start with saying I’m quite new to this so please forgive any ignorance. Been floating around for a little while and have been enjoying myself.

So funny enough this post here was originally written out in the inverse. I was having this problem. But while writing it I seem to have come across a set of steps that fixed the issue. So since it was very strange, and I already have a lot typed out, and I couldn’t find any other reference to something like this happening, I morphed this post into information that someone who is having the same bizarre problem might be able to use. I’m not quite sure if its in the correct catagory anymore, but “share information” is under Projects so that’s where I’ve selected.

I picked up a Proxmark3 Easy quite a while ago, toyed around with it, and then got separated from it in a move. I have recently been reunited with it and was attempting to reflash it to the most current Iceman firmware by means of windows and ProxSpace.

Now, this is really strange. When I plug him in, he pops up at COM3 just fine. I then attempt to flash the bootloader with “./pm3-flash-bootrom”. It finds it on COM3, and then the PM3 disconnects (I assume a reboot for flashing mode?), and then the program never get to continue because when he reconnects, he is now COM4! He was effectively “dodged” the flashing process. I can see this in the Device Manager for windows. (Something to note, when I unplug and replug him, he jumps back to COM3) Here is a screenshot:

So next thing, will it flash correctly with it on COM4? It seems to at first and then it seems to have not. Here is a screenshot when I run it on COM4:

Looks like it has worked. And something to note, Device Manager now declares the PM3 to be back on COM3. But. When I go and run “./pm3-flash-all” it tells me the bootloader is outdated, and that I need to run “./pm3-flash-bootrom”:

But its a trap!! And here is where I seem to have found the solution. If you do run “./pm3-flash-bootrom” as it recommends, the same exact “dodging” behavior occurs and it moves back to COM3. Instead, what I did while it was on COM4, was run “./pm3-flash-fullimage” and behold, it worked.

Not only this, but it appears to be stable and no longer “dodging” firmware flashes. I can run “./pm3-flash-bootrom” freely and it has chosen to stay on COM4 no matter how many times I unplug or reflash it.

Well this has certainly been interesting. I’m not sure what I could have done to cause something like this but hopefully this post can help someone else out.

Have a good day everyone and happy projecting!

P.S. Shoutout to amal for the humor in his getting started post I was following. Only thing that kept me sane through this.


No issue at all, but I just shifted it to Support, basically it was a question and answer in the one post and it can be used to support somebody experiencing the same /similar problem, rather than a project for somebody to “make”.

Thanks for the info though, I sure it will come in handy :+1:

1 Like

Where did you get your PM3 easy from? If it wasn’t from DT / KSEC with preflashed rrg fork, then the reason is likely that it was flashed with either a modified version of rrg, or the original PM3 firmware, which has a slightly different bootloader and as such is picked up by windows as a different device. Once you’ve flashed it with rrg, it’ll hopefully stay that device unless you choose to flash the original pm3 firmware.

Hope that helps!