Proxmark3 Easy Flash Error

So I just got a Proxmark3 Easy 512k and I’ve been playing around with it in preparation for my next implant. Yesterday, I was able to flash both the official repo and Iceman’s repo bootloaders/full images. However today, after swapping back to Iceman’s, I’ve run into an error with flashing the full image, which I suspect is also the reason my Proxmark throws a fit when I try to “auto” (i.e. disconnects and reconnects a bunch of times). I have tried both the pm3-flash-all, flashing the bootloader and fullimage separately, and just flash-all then both. At this point, I’m now wondering if there’s a way to just straight factory reset the PM3 and so I can just reinstall the firmware.

I should mentioned I have reinstalled ProxSpace, and that I am able to run the official repo no problem, but I think that may be because it’s smaller and doesn’t access the deeper storage that Iceman’s does. Attached you can find the error in question, which looks to be a locked segment?

have you tried a
make clean && make all

Try that, If it doesn’t work, I see what I can find in the forums for ya’

There are a few threads around with similar issues

Let us know either way

1 Like

Indeed that make clean && make all is part of the installation procedure and happens in both the official and Iceman, but I can try again as I’ve decided I’ll set up to directories, one for each of the repos for testing purposes.

does the easy have a button?
make clean && make all

Then unplug, hold down button, keep holding button, plug in, keep holding button for >30secs
MAYBE?? Voila!

I’m not an expert, not a fan of the PM3
I’ll find you a thread… that will be of more use to you

It is addressing the right com port i.e. 5 in the pic above (thats also the one in the scripts to begin with)?

does the easy have a button?

It does and functions similarly to the RDV4

I’m not too familiar with using the PM3 on Windows using Proxspace. I have (and do) use PM3 on Windows using WSL and/or Linux OS.

Could be a privilege mismatch? Make sure the terminal you are running is with admin privileges.

Ensure you have the correct drivers installed for the COM port of the PM3. Also need to ensure that the drivers are correct for when the PM3 button is pressed on startup.

Since you have a PM3 Easy you should also be specifying when flashing that it’s not the expected RDV4.

Did you complie for RDV4 hardware? That’s the default, but since you have an Easy you need to config for “OTHER” hardware and compile for that. Check the “platform” section of the advanced config;

1 Like

Yep, it does have a strange habit of changing COM ports when flashing the fullimage unless I explicitly hold down the button when powering on the device and keeping it held.

I thought about admin privileges as well, but when I attempt to run the “runme64.bat” or “runme.bat” as admin, the command terminal will open for a brief second, then disappear. It appears to have some predisposition to being called normally.

Yeah I made that mistake the first time I was make clean && make all, but since then I’ve just always renamed the Makefile.platform.simple and just commented out the RDV4 line and uncomment the PM3 generic. It doesn’t have seemed to make a difference, but that was my first thought as since it seemed like the flasher was going beyond its limits, so to speak.

Overall, while it’s been a not super great experience, I can certainly appreciate the flexibility of a device like the PM3 and PM3 easy, but damn are they right when they say it’s not user friendly. @Pilgrimsmaster, if you’re not a fan of the PM3, what do you use for read/writing to your implants?

An RDV4… but that doesn’t mean I like it.
Purely a means to an end.
I would prefer to have something small and “robust” I can just throw in my bag,
pull out,
read - write - done

There are125kHz readers you can plug into your phone… if only they could write!

There is the Keysy, If only it had a more suitable antenna for xSeries, But It would be interesting to see if it could read a “New” LF Flex?, I will try this when I am out of Lockdown ( I’m currently separated from my FlexMT ), Even if it works to read, it would be a pity we wouldn’t be able to write with it, because it uses a proprietry write method and will only write to Keysy products :confounded:

The Blue cloner would be awesome IF it didn’t write it’s stoopid password, it had a more suitable antenna, and could write to HF implant(s)

A while ago there was mention of a DT reader / writer project, but it never eventuated, The market would likely be too small to make it viable.
Paraphrasing Amal here ~“We have the Proxmark, that will do what we want, we would be better of spending time and money elsewhere”~

I am really hoping that the Flipper ,that, as well as reading HF and LF, it will be capable of writing also.
In my opinion, the Holy Grail of a what I want:-
HF & LF, small form factor, easy to use, basic interface with expansion to Phone App, and then add the other functionalities ontop :cherries:

1 Like


I just experienced this same issue. I use the Proxmark a lot and found a few things might be wrong.

  1. If you were making edits to the code like I was you need to redownload the proxmark flash files from the website.
  2. if you have a blueshark attached, remove it from you proxmark.
  3. go to your device manager settings once connected and force it to stay on COM 8 in the advanced settings.
  4. also try a new cable. I somehow managed to break my cable in the process. But once I did all of these steps I was able to reflash the proxmark with the new downloaded scripts and it works again.

I hope this helps.

1 Like

FYI – I’ve fixed the randomization of the COM ports under Windows.

That randomization was caused by the PM3 devices not previously exposing a unique serial number (via the USB protocol). When you update the bootloader to a version(*) with the above fix included, it will then expose a unique ID, and your COM port will be (mostly(**)) static / safe from changes.

(*) it’s part of the iceman fork main branch already, since February 19th, 2023. The last official release as of today was Nitride (v4.16191) was released January 29th, 2023, and thus does not have this fix. Therefore, you would need to build the binary yourself.

(**) If it was COM4, and the PM3 is not connected, then something else might come along and “claim” COM4. To reduce that chance, you could assign the PM3 device a higher number COM port (e.g., COM87).