Proxmark3 easy git error

Ive gotten to the step where i need to pull the repoman repository with the “git clone” command but it errors out sayng “bash: git: command not found” I have not found anything helpful with other forum on how to fix this issue.

make sure you have git installed. What OS are you using?

You may also need to sudo it

If it was a lack of permissions It would give a permissions denied rather than command not found. That and git does not need super user permissions. If it does I would be concerned.

Actually I’ve had many commands simply unreachable from the regular user level that you have to use sudo for them to be found, it’s not terribly uncommon, and though I didn’t specifically remember if git needed superuser permissions, I figured it might be likely as it does try to create a directory

1 Like

I am using windows 10. This is version 3.9 of proxspace. sudo also gives me a command not found error. where would i get git if i need to install it and does it need to be put in a particular folder?

I find deploying proxspace to anything other than C:\proxspace can cause path errors, especially during tool compilation… where is your proxspace deployed to?

1 Like

I have it deployed to C:\Proxmark\proxspace. Do you just move the proxspace folder or do you need to remove the folder in a certain way and reinstall the program in the c drive

Hmm I think that path should be fine actually… no spaces or anything crazy. I’d just kill the whole proxspace folder and try deploying again from scratch

A soon as i reinstalled it directly under the C:\ it installed with no problem as is working exactly as expected.


@amal has updated the getting started instructions today to reflect putting it directly under c:/ (even though he missed a reference to C:/working/proxspace)

Glad my frustration can help others dodge the same frustration.


The thing with proxspace is that it does not like spaces in its working path directory.
So a path of “C:\Users\Jirvin\My Documents\RFID Hacks\proxspace” will not work
But a path of “C:\Users\Jirvin\RFIDHax\proxspace” will work.


In this case a deployment to C:/Proxmark/proxspace failed to work.

I don’t honestly know what could have caused that.

Are you sure the path used forward slashes (/) and not back slashes ()?
I dont think that would be an issue though.

Are you also able to reproduce the issue again and again? Could be something that can be patched but need to be able to consistently reproduce the issue

I wasn’t having the issues, and I am a long time Unix sysadmin so forgive me if I am getting the slashes wrong.

I had no issues with Windows 10, Linux or Android.

@SilenceFalls was the one with the problem and a reinstall with a different path fixed his issue.

I have not tried recreating the issue on Windows and my install worked perfectly.

I have a laptop that i plan to install proxspace on as well which should have a similar program layout so i can attempt to recreate the issue. The original folder path was with back slashs C:\Proxmark\ProxSpace