Proxmark3 on Android?

Has anyone had any luck getting their pm3ez to work on (unrooted) Android with current firmware (Iceman

I’ve tried:

Termux - doesn’t have /dev/ttyxxx access privileges unrooted
Walrus - detects pm3 but never connects
RFID Tools - wrong client version, can’t figure out how to update
AndProx - detects pm3 but never connects

I can get it to work with rfid tools if I flash that client’s fw version, but I’d like to use the newest.


Reddit seems to suggest you can use a TCP-UART app, but I haven’t tried it yet:

1 Like

Do you happen to know the pm3 client command to connect via tcp? ./pm3 still tried to connect via ttyacm0. ./pm3 -h doesn’t seem to list a way either.

1 Like

./pm3 tcp:localhost:<chosenPort>

according to :

For those playing at home the above command wasn’t actually taken directly from the link, the mistake was mine, not theirs, my bad

Hmm. I’m still getting

[!!] Script cannot access /dev/ttyXXX files, insufficient privileges

Seems like it’s still attempting to connect via USB.

1 Like

Try this one:

./client/proxmark3 tcp:localhost:<chosenPort>

That works! Thanks!

Why does that client work and not pm3? Pm3 configured for just tty or something?

1 Like

Great question, I wish I knew

But I’m not one to pass up the chance to bother someone:

@iceman, would you mind explaining the difference between ./pm3 and ./client/proxmark3?
Or anyone else who knows :classic_smile:

1 Like

Haha. Beautiful.

Well thanks for your help. Your Google fu process to be better than mine!

1 Like


is a shell script where it tries to detect the serial port automatic and help you list and choose one to connect to the proxmark3 client. You can see it as a wrapper script. It passes some help text, call it with -hh to get the client full help text.

is the executable