Proxmark3 rdv4 not showing up after flash

I’ve picked up a rdv4 with bluetooth 512 and trying to get it to work with mac (Intel).

I was able to flash successfully (pressing button when plug to enter bootloader lights 0101, ./pm3-flash-bootrom and ./pm3-flash-all) with all results ok and all done. When I try ./pm3 though, it is “Waiting for Proxmark3 to appear…” and cannot detect the port. The device when plugged in briefly flashes first red light and then all the red lights are off.

I’ve tried both building Iceman repo from source and using brew as suggested by posts I found online, they have same result of cannot find the device.
The only time the proxmark is detected by my mac is when pressed the button and in bootloader mode.

What could be the issue since flash seems to be successful? Thank you

Your platform file was left unaltered and said rdv4?

Are you using USB to do this or Bluetooth? I don’t know for sure but you might need additional compile options to enable Bluetooth

Makefile.platform file is updated to just “PLATFORM_EXTRAS=BTADDON” (should default to rdv4, correct?)
Below are the options output when running make all,
I am doing the flash over USB, not using bluetooth (switch is off)

Version info:      Iceman/master/v4.16191-102-gd516c36ad-dirty
Platform name:     Proxmark3 RDV4
PLATFORM:          PM3RDV4
PLATFORM_FPGA:     xc2s30
Platform extras:   BTADDON
Standalone mode:   LF_SAMYRUN
[*] MAKE client/all

Ok and you are running pm3 client with USB too?

correct, but the port /dev/tty.usbmodemiceman1 is not available except when the proxmark is put in bootloader mode when plugging usb in

Hmm… I would try holding the button and running flash-all

Yeah, tried that (and various other combinations of flash commands) and no response after flash command successfully completes

What should I look for as signs of life generally speaking? After the flash all the red LED turn off, and when plugging it in again (without pressing button) the second and fourth flash, then first, then all are off. Four blue LED are always on

Got a Bus Pirate to try out JTAG debugging, errors out with invalid cpu IDCODE. does this mean there is an issue with the device, or is it a connection issue?

Open On-Chip Debugger 0.12.0
Licensed under GNU GPL v2
For bug reports, read
DEPRECATED! use 'buspirate port' not 'buspirate_port'
DEPRECATED! use 'buspirate vreg' not 'buspirate_vreg'
DEPRECATED! use 'buspirate mode' not 'buspirate_mode'
DEPRECATED! use 'buspirate pullup' not 'buspirate_pullup'
DEPRECATED! use 'adapter speed' not 'adapter_khz'
adapter speed: 1000 kHz

Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.
Warn : Transport "jtag" was already selected
DEPRECATED! use 'adapter speed' not 'adapter_khz'
adapter speed: 1000 kHz

Info : Some stale data from a previous connection was discarded.
Info : Buspirate JTAG Interface ready!
Info : This adapter doesn't support configurable speed
Info : TAP sam7x.cpu does not have valid IDCODE (idcode=0xfffffffe)
Error: sam7x.cpu: IR capture error; saw 0x0e not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : Embedded ICE version 0
Error: unknown EmbeddedICE version (comms ctrl: 0x00000000)
Info : sam7x.cpu: hardware has 2 breakpoint/watchpoint units
Info : starting gdb server for sam7x.cpu on 3333
Info : Listening on port 3333 for gdb connections
Info : Halt timed out, wake up GDB.
Error: timed out while waiting for target halted

Warn : Flash driver of sam7x.flash.0 does not support free_driver_priv()
Warn : Flash driver of sam7x.flash.1 does not support free_driver_priv()
Info : Shutting down buspirate.
Info : Buspirate switched to normal mode

Oh odd… no idea what that’s about. You might try hitting up Iceman on his discord server


@sd9 Did you ever get this working? Facing the same issue here :slight_smile:

Nope, tabled the issue for a while since I’ve been pretty busy with other projects… if you find anything that helps please let me know though :smile: