Proxspace pm3 not working in win10?

Followed this installation guide. Win10, proxmark 3 easy.

After everything is installed and I’m in proxspace, the pm3 commands don’t seem to do anything, but they are vaguely responsive?

For example if I run ./pm3-flash-bootrom it does nothing, but if I run ./pm3-flash-bootrom -h it shows the help menu. Running --list shows the connected device

How come it just returns with no text when I run a command like ./pm3-flash-bootrom? Am I missing a dependency or something? I ran into no errors when running runme64

I’ve uploaded the full log below beginning with the runme64 command up to where I’m stuck.
ProxSpace v3.10 - MINGW64~proxmark3.txt (98.9 KB)

I’m not sure but I don’t actually run proxspace in PowerShell, I run it from a traditional command prompt. It probably doesn’t matter, but it’s a difference I’ve noticed.

It’s odd how the flash util isn’t actually attempting to communicate. When you run pm3-flash-bootrom does it immediately return to the proxspace prompt? Nothing else happening?

Yep, returns right back to proxspace. Cmd doesn’t seem to help either, same response.

I’d love to figure out what the heck is going on, but I think I’m also going to pursue wsl in the meantime since the instructions to install via wsl seem simple enough

1 Like

If I had to take a stab I’d say wipe it and start over in a standard command prompt… but wsl is also an option.

Tried it through standard cmd more than once before swapping to terminal. Made no difference

Running as administrator?


interestingly if I disconnect the proxmark then run ./pm3 it will say “Waiting for Proxmark3 to appear…”

when I plug it in, it goes back to proxspace

well if anyone figures it out let me know, for now I just installed wsl and got it working through that

1 Like