Reading LTO-CM tape RFID

I’m attempting to read an LTO-7 tape that the drive refuses to load. I suspect the LTO-CM RFID isn’t working.

A number of people have said the ACR122U should read LTO-CM tags, so I bought a cheap one from Amazon

to check it, but in Linux (using nfc-list) and in Windows (using Advanced Card Systems nfctoolsgui.exe) it simply doesn’t “see” any LTO RFID I try.

BUT it will cheerfully react to & read various other RFIDs.

Does this suggest a hardware fault with the reader, or does the reader have to be placed into some special mode?

I’m tempted to just return it and get a cheap Proxmark3 clone; any recommendations?

As you may have guessed, I’m new to all this :stuck_out_tongue:

2 Likes

Did you try this?

Seems like exactly what you want.

2 Likes

Thanks for the reply, but yes, I did :frowning:

1 Like

So you have an ACR122U.

It can read various RFID chips.

You have one LTO tape that you believe is faulty and you can’t read the LTO-CM from it with the ACR122U.

Are you saying that you haven’t been able to read any LTO-CM with the ACR122U and that you tried some that should work?

Did you try positioning the LTO-CM in various places and angles on the reader? If you are unsure where it is in the cartridge there is a cut open cartridge on the wikipedia page.

Thanks for the reply.

Yes, I’ve tried a variety of LTO tapes and can’t read the LTO-CM of any of them. I even went so far as to open one up, and pull the RFID tag out of it and place it directly on the reader and got nothing.

1 Like

I don’t know the reader in question myself, but it does sound like it is applying more in the way of smarts than you need and not telling you about the tags that it can’t understand.

If you are going to go down the Proxmark3 route I would suggest a Proxmark3 Easy from Dangerous Things. I am just a happy customer, but it is a lot cheaper than an RDV4 and should be fairly straightforward to use to read the tags even if it doesn’t know what it is looking at.

I hope someone else has some useful ideas but I am afraid I can’t think of anything else to try with the equipment you have.

If you are returning your “cheap” ACR to Amazon, you might try purchasing a cheaper but guaranteed genuine one from KSEC (as I see you are in the UK) as apparently there are less reliable counterfeits around.

2 Likes

Thanks. I’ve decided to take your advice & return my “cheap” (actually more expensive) ACR122U to Amazon and buy one from KSEC.

Interesting to see if it works any differently… I’ll post a follow up with my findings.

1 Like

Good luck, I am in the US or I would see if we could meet up to test a Proxmark3 Easy against it.

I could actually read LTO-CM with “nfc-ltocm” software that have been posted at the top. Just so you know. I also have Proxmark3 and this woks, too.

2 Likes

Welcome, and thank you for letting us know.

Well I bought another ACR122U reader, this time from KSEC. The label on the back uses slightly different typefaces and fonts so maybe the Amazon one was a fake. But in any case… this new one doesn’t work any better.

I created a fresh install of Ubuntu (16.04 for my ESXi 5.5u3 box), and then:

installed pcscd and pcsc-tools

blacklisted pn533_usb, pn533 and nfc in /etc/modprobe.d/blacklist.conf

installed the ACR122U drivers for xenial from the ACS website

installed libnfc-dev and libnfc-bin

installed & compiled nfc-ltocm

So the reader works under pcsc_scan and nfc-list as I would expect, reading Yubikey and other RFIDS, but simply does not react to any LTO.

When I try nfs-ltocm it reports:
“Error: error with LTOCM REQUEST STANDARD, no tag present?”

I don’t really want to have to fork out for a PROXMARK3 to do this but I’m at my wit’s end.

Any ideas?

Can you return the ARC122U and pay the smaller difference for the PM3?

Maybe somebody that is on here may be near you and may be able to send you their PM3 to try
or
you could send them the tape to try?

What city are you located in?

Are we sure the lto chip even works?

The readers are in “as new” condition and were bought over the Internet so I should be able to get my money back.

I’m in SW London.

I’ve tried 6 different LTO tapes (LTO1 thru LTO5, & LTO7), all of which are deemed fit by their respective drives, so yes :frowning:

When you put the tapes on, do you get a beep and a green light on the acr122u? Sorry if this has been answered already

I’m not sure what you Covid lock down situation is at the moment, and you will probably wato contact them first, but I’m pretty sure KSEC are in the Canary Wharf area, so just a quick train trip for you, they may be able to help you out @KaiCastledine

It has not, I don’t know the acr122u at all. The LTO standard does include an rfid chip inside the cartridge. Some people optionally add RFID tagged labels to the outside of the case. According to a veritas thread on the subject the content of the chip contains some raw data that is not particularly useful. If the acr122u is looking for anything other than raw reads it might not be able to read the tag.

Okay, it seems that the software installation (nfc-ltocm) has been completed, and the ACR122U has been detected from your PC based on your error message report.

I guess that the LTO cartridges is not placed on the reader properly. I would recommend to see the following YouTube video to make sure how you should locate the cartridge.

This video uses Proxmark3, but it would give you an idea of the location. Since the allowable distance between chip and reader is roughly ~1cm or so, you might need to do some “try-and-error” to find the right location.

Location of LTO cartridge memory chip:
https://www.fujitsu.com/th/en/products/computing/storage/tape/eternus-lt/feature/STRSYS_a02.html

3 Likes

Can we take a step back a sec, you said one of the tapes was not working in the tape deck so your trying to read the rfid tag.

Why? The rfid tag if I remember rightly is primarily there for when you achieve loads of tapes you can easily read the tag to find out what data is on there with that said the tag is programed separately at least it was when I did it and only with the details we gave it I.e. server backup 12/02/19.

I’m just wondering what your hoping to achieve?