Samsung NFC reader wont work after reading one card in taginfo app

Hey all new to this site so appreciate any help that someone can extend here. I have literally had my new Samsung S23 for about 8 hours now.

I was excited to use the tag info app as my iPhone is of course, “limited” this category ( I suppose now I know why haha).

Anyway, upon scanning the NFC card (which is just an old hotel key), I was unable to scan any more NFC cards from there on!! The NFC reader won’t even activate when I put a tag or card near the phone. Here are the trouble shooting steps I have already performed none of which have worked…

  1. Toggled the NFC reader on/off
  2. Deleted/reinstalled taginfo app
  3. Restart phone
  4. Erased all settings.

I have not factory reset the device which is not a big issue for me To Do since the phone is new. But i’d rather avoid it if I can.

Being me, this would happen right out of the damn box. :roll_eyes:

Oh that’s odd. Turn off all the Samsung NFC stuff like Samsung pay and Samsung’s version of Android beam… and check for field with an RFID diagnostic card or field detector to see if the NFC stack is even functional

Thanks I finally got it working that was extremely odd. I Tried a few different things but I think it was Samsung Pay that was turning the NFC reader off.

1 Like