[SOLVED] Errors when compiling for PM3 easy on windows 10

This used to work just fine on my computer up until today where I decided to update the software since a new version has since come out when I bought my PM3 Easy.

I deleted the old proxmark folder and started over fresh in a new location with a new download.

Ive followed all the instructions (EDIT: Instructions from amals getting started with pm3 guide) and no matter what I try I keep getting these errors during the “make -j8 all” step. https://i.imgur.com/RIKfpBW.png.

I run autorun64, then I clone the git repo. I create the Makeplatform.platform file and adjust it to work with my PM3 easy by commenting out the top line and commenting in the second line for PM3GENERIC.

Once thats done I enter the proxmark3 folder with “cd proxmark3” then use the “make -j8 all” command which goes well for the most part except when it gets to the end.
This happens with both “make -j8 all” or “make clean && make all”. Running the batch file as admin and turning off all antivirus doesnt help either.

Ive tried doing all this with my PM3 plugged in and also unplugged as well to no help. Ive also tried downloading an old version of the PM3 setup and that didnt work either. Ive restarted my computer a bunch of times as well, that didnt help either.

The folder its running out of is close to root on the drive and has no spaces. “C:\proxmark\ProxSpace” Ive tried doing this on various hard drives too in case it was the C drive it had issue with due to system protections and what not.

Does anyone have any insight as to why this is happening? It would install fine on this this computer about 3 years ago when I bought my PM3 but now it just doesn’t want to compile for some reason.

Any help would be much appreciated! Thank you.

which instructions buddy?

These ones?

1 Like

Yeah sorry I should have specified. I followed that guide by amal, same one I followed when I first got the pm3

Trying to recompile the latest source throws the same error for me, you can use the latest release instead of git clone-ing the source, or you can wait a day or two and they’ll probably fix it

Link to the releases:

Commands to run in ProxSpace if you want to go that route:

wget https://github.com/RfidResearchGroup/proxmark3/archive/refs/tags/v4.18341.tar.gz

tar -xvf v4.18341.tar.gz

cd proxmark3-4.18341

And then you can continue from the make clean && make -j step as normal


ah of course! Should have tried using the latest release instead of the live git repo. That worked a charm thank you!