Updating the Proxmark3 Issues

Thanks for helping. I’ve spent a few days trying to update my proxmark3 and I am stuck.
I think it might be a PC problem as this happened last time and rebooting my PC fixed the issue but not this time.
I deleted everything (several times)and restarted several times, etc, bla bla bla.
When I try to use any of the flash commands I continue to get the error:

pm3 ~/proxmark3$ ./pm3-flash-bootrom
[!!] In devel workdir but no executable found, did you compile it?

When compiling it (make clean && make -j8 all) I notice some errors, I get several pages of these:

[=] CXX proxmark3
C:/work/ProxSpace/msys2/mingw64/bin/…/lib/gcc/x86_64-w64-mingw32/10.3.0/…/…/…/…/x86_64-w64-mingw32/bin/ld.exe: obj/mifare/aiddesfire.o: in function open_aiddf_file': C:\work\ProxSpace\pm3\proxmark3\client/src/mifare/aiddesfire.c:233: undefined reference to json_load_file’
C:/work/ProxSpace/msys2/mingw64/bin/…/lib/gcc/x86_64-w64-mingw32/10.3.0/…/…/…/…/x86_64-w64-mingw32/bin/ld.exe: obj/mifare/aiddesfire.o: in function aiddf_json_get_str': C:\work\ProxSpace\pm3\proxmark3\client/src/mifare/aiddesfire.c:260: undefined reference to json_object_get’

Then after several pages of the above items, at the end I get:

C:/work/ProxSpace/msys2/mingw64/bin/…/lib/gcc/x86_64-w64-mingw32/10.3.0/…/…/…/…/x86_64-w64-mingw32/bin/ld.exe: obj/pm3_pywrap.o:pm3_pywrap.c:(.rdata$.refptr.PyObject_GenericGetAttr[.refptr.PyObject_GenericGetAttr]+0x0): undefined reference to `PyObject_GenericGetAttr’
collect2.exe: error: ld returned 1 exit status
make[1]: *** [Makefile:768: proxmark3] Error 1
make: *** [Makefile:171: client/all] Error 2
pm3 ~/proxmark3$

Does anyone know what might be wrong? TIA.

Anytime somebody has an issue with PM3 set up, my default is to suggest a clean build, as fault finding can often take longer.

A couple of questions:

Where did you buy your proxmark3 from?
If not DT, can you provide a link?

Which guide did you use for set up?

If you didn’t use Amal’s, i would suggest you give it a try.

Delete EVERYTHING, and start afresh

  • Here’s Amals very thorough guide
  • Here’s my abbreviated, barstardised and blatently plagerised version of Amals

Thanks for the reply. It was purchased thru DT. I’ve had it for a year+ working.

Every time I try to update, I get some similar problems, and I need to restart all over again.
Last time a PC reboot worked.

I’ve erased everything several times and even created a new sub folder to start with, incase there were some hidden files/folders causing the problem. I’ve probably have 10+ hours into it. started from scratch 6 or 7 times, all with the same errors.

I follow Amal’s video and page instructions every time. I’ve also searched this forum and the Discords forum. My brother is familiar with Linux and Python, He is thinking there is a permission issue when the files are trying to link or create a path. I’m going to try later today on another PC, to prove it’s my PC or somehow the software or PM3. I can update later with results.
Again thanks for your time.

1 Like

Not sure what is going on, but I finally got it to work. Reloaded everything again, and again it failed with same errors when compiling. I erased just the proxmark3 directory and reloaded software and this time it compiled and flashed…

1 Like

that sounds annoying!

  1. check that any antivirus is disabled during your attempt to set up proxspace and compile

  2. when it’s time to update, go into proxspace and at the pm3 prompt, cd into the proxmark3 directory and do a “git pull” to update the codebase… then “make clean && make all”… then flash with “./pm3-flash-all”

1 Like

#2 was the 1st thing I tried.
Next time I will certainly check or disable my antivirus if and when I get stuck.
Its working for now, so I’m going to leave it alone for a while.

Thanks again for the replies.