VivoKey App iOS Spark 2 Registration Bug

I’ve finally managed to register my Spark 2. Tapping the tips icon in the app might resolve this issue for you, since it switches the in app activities :). Kind of a workaround, but worth noting.

Hi, fellow biohackers. Yesterday I got my Spark 2 implanted and now I’m trying to set it up in the VivoKey iOS app. The issue is, everytime I launch the app, successfully read the chip, fill in the name and email in order to register it to an account, it just throws me back at step one. What I’ve noticed is that if you look closely, the second time I scan the chip on the video, the step to which the app should have proceeded (PIN Creation) but instead returned me to the start, blinks in the background for a second. Tried reinstalling the app, running it with VPN both on and off, different emails in case my domain was considered as a spam, name with only Latin characters, etc. Nothing seems to work. Any ideas on how to fix this problem? Thanks in advance! :slight_smile:

Try to use only standard charset.
If work there is a litle bugfix for the app

As stated in the original post, I’ve tried that already.

Hey buddy
Between them, one of these guys should be able to help


1 Like

Not sure if related, but I had a similiar problem once AFTER my Spark2 had been registered for a few months. I had done all the uninstall/reinstall to no avail, but then an hour or so later it worked again like normal.
Perhaps just a transient issue that clears itself up, hopefully anyway.


Could be a server related issue aswell. Hopefully I’ll have it sorted out soon. Thanks :).

1 Like